Skip to content
Laskyr

filament/filament security advisory

CVE-2026-84307: Filament: Password validity disclosure for accounts denied panel access on login page

CVE-2026-84307 is a low-severity user enumeration vulnerability in the PHP package filament/filament (CVSS 3.7), published 1 September 2026. It is fixed in 4.12.5 and 5.7.5, one per release line; earlier versions on each line are affected. It can be exploited without an account.

low 3.7 published 2026-09-01 · updated 2026-09-09

Fixed in filament/filament 4.12.5 and 5.7.5

This user enumeration issue affects filament/filament in 2 release lines: >= 4.0.0, < 4.12.5; >= 5.0.0, < 5.7.5. Upgrade to the fixed version for your release line (4.12.5 and 5.7.5). The newest release, 5.11.1, is not affected.

Affected versions
>= 4.0.0, < 4.12.5
>= 5.0.0, < 5.7.5
Fixed in
4.12.5, 5.7.5
Newest release
5.11.1
Severity
Low · CVSS 3.7
Type
User enumeration
CWE-204
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your filament/filament version affected?

Run composer show filament/filament in your project, then enter the version. We check it against this and every other known filament/filament advisory.

Who can exploit CVE-2026-84307

CVSS vector (scored by GitHub): CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N

Your app is only exposed if it uses the affected part of filament/filament. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-84307 in filament/filament

  1. Find the installed version: composer show filament/filament. If you never required it yourself, composer why filament/filament shows which package pulls it in.
  2. Update it: composer update filament/filament --with-all-dependencies. You need the fixed version for your release line (4.12.5 and 5.7.5).
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "filament/filament": "^5.7.5" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-84307.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for user enumeration issues while the upgrade waits. None of it replaces the fix.

The CVE-2026-84307 advisory

Filament is a collection of full-stack components for accelerated Laravel development. From 4.0.0 until 4.12.5 and 5.7.5, packages/panels/src/Auth/Pages/Login.php presents the multi-factor authentication challenge before evaluating canAccessPanel(). For an account that canAccessPanel() denies, submitting the correct password renders the MFA challenge while an incorrect password returns the generic authentication failure, allowing an unauthenticated attacker to confirm whether a candidate password is valid for that account. When email-based MFA is configured, the correct-password path also sends a login code to the account holder. The issue applies only to accounts that have MFA enabled and are denied panel access. Authentication is not bypassed because canAccessPanel() still runs after the challenge, and no session is created. This issue is fixed in versions 4.12.5 and 5.7.5.

Description from the CVE record, published by GitHub (the CVE Numbering Authority), via the NVD entry for CVE-2026-84307. Advisory title: “Filament: Password validity disclosure for accounts denied panel access on login page”.

References

Other filament/filament advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit