filament/filament security advisory
CVE-2026-104181: Filament: Multi-factor authentication (app) management actions do not require password reauthentication
CVE-2026-104181 is a medium-severity authentication bypass vulnerability in the PHP package filament/filament (CVSS 5.4), published 1 October 2026. The advisory does not name a fixed version. Exploiting it needs a low-privilege user account.
medium 5.4 published 2026-10-01 · updated 2026-10-06
- Affected versions
- >= 4.0.0, <= 4.13.2
>= 5.0.0, <= 5.8.2 - Fixed in
- not stated
- Newest release
- 5.11.1
- Severity
- Medium · CVSS 5.4
- Type
- Authentication bypass
CWE-306 - Exploited in the wild
- Not on the CISA KEV list
checked 2026-11-04
Is your filament/filament version affected?
Who can exploit CVE-2026-104181
- Access: A normal, low-privilege user account in the app.
CVSS vector (scored by GitHub): CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L
How to fix CVE-2026-104181 in filament/filament
- Find the installed version:
composer show filament/filament. If you never required it yourself,composer why filament/filamentshows which package pulls it in. - Update it:
composer update filament/filament --with-all-dependencies. - If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example
"filament/filament": "^5.11.1"if you can take that version), or upgrade the package that requires it. - Run
composer audit. It reads the same advisory data and should no longer list CVE-2026-104181. - Commit composer.lock and deploy it. On the server, run
composer install --no-devfrom the lock file, notcomposer update.
If you cannot upgrade yet
- Remove accounts you do not need and review what each role can do.
- Put the admin area behind a VPN, IP allow-list or extra login until you upgrade.
- If your app does not use the affected feature, note that in your audit, but still plan the upgrade.
The CVE-2026-104181 advisory
Filament is a collection of full-stack components for accelerated Laravel development. From 4.0.0 until 4.13.3 and 5.8.3, app-based multi-factor authentication management actions do not consistently require confirmation of the current password. An attacker with access to an authenticated user session can set up app-based MFA and obtain recovery codes, or disable app-based MFA and regenerate recovery codes by supplying an existing app code or recovery code, without knowing the account password. Email-based MFA is not affected, and the issue does not independently permit an unauthenticated sign-in, but changing the app-MFA configuration may lock the legitimate user out. This issue is fixed in versions 4.13.3 and 5.8.3.
References
- GitHub advisory GHSA-7m6h-rg42-m449 github.com
- Fix commit 6d4dae6 github.com
- Pull request #20522 github.com
- Release v4.13.3 github.com
- Release v5.8.3 github.com
Other filament/filament advisories
- medium CVE-2026-84306: Filament: Multi-factor authentication (app) codes can still be used after a newer code has been used 2026-09-01
- low CVE-2026-84307: Filament: Password validity disclosure for accounts denied panel access on login page 2026-09-01
- high CVE-2026-77567: Filament: Multi-factor authentication (app) can be bypassed when recovery codes are enabled 2026-09-01
- high CVE-2026-48505: Filament: Multi-factor authentication (app) recovery codes can still be used multiple times via concurrent submission 2026-06-25
- medium CVE-2026-48500: Filament: Unauthenticated temporary file upload on auth pages 2026-06-23
- medium CVE-2026-48166: Filament: Timing-based user enumeration on login page 2026-06-23
Related
Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.
Ask about a fixWhere this data comes from
- Affected and fixed versions: the Packagist security advisories API (GitHub Advisory Database and FriendsOfPHP), the same data
composer audituses. Synced 2026-11-03. - Description, score, weakness and references: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Exploited-in-the-wild status: the CISA Known Exploited Vulnerabilities catalog, checked 2026-11-04.
- Compiled by Daniel Lasek at Laskyr from the sources above. The summary, “who can exploit it”, “how to fix it” and hardening sections are our plain-English reading of the record and are generated from it. The quoted description is the record's own text. Spot an error? Tell us.