filament/filament security advisory
CVE-2026-48500: Filament: Unauthenticated temporary file upload on auth pages
CVE-2026-48500 is a medium-severity missing authorization vulnerability in the PHP package filament/filament (CVSS 6.5), published 22 June 2026. The advisory does not name a fixed version. It can be exploited without an account.
medium 6.5 published 2026-06-22 · updated 2026-10-25
- Affected versions
- >= 3.0.0, <= 3.3.51
>= 4.0.0, <= 4.11.4
>= 5.0.0, <= 5.6.4 - Fixed in
- not stated
- Newest release
- 5.11.1
- Severity
- Medium · CVSS 6.5
- Type
- Missing authorization check
CWE-862 - Exploited in the wild
- Not on the CISA KEV list
checked 2026-11-04
Is your filament/filament version affected?
Who can exploit CVE-2026-48500
- Access: No account. Anyone who can send a request to an app that uses the affected code.
CVSS vector (scored by GitHub): CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L
How to fix CVE-2026-48500 in filament/filament
- Find the installed version:
composer show filament/filament. If you never required it yourself,composer why filament/filamentshows which package pulls it in. - Update it:
composer update filament/filament --with-all-dependencies. - If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example
"filament/filament": "^5.11.1"if you can take that version), or upgrade the package that requires it. - Run
composer audit. It reads the same advisory data and should no longer list CVE-2026-48500. - Commit composer.lock and deploy it. On the server, run
composer install --no-devfrom the lock file, notcomposer update.
If you cannot upgrade yet
- Remove accounts you do not need and review what each role can do.
- Put the admin area behind a VPN, IP allow-list or extra login until you upgrade.
- If your app does not use the affected feature, note that in your audit, but still plan the upgrade.
The CVE-2026-48500 advisory
Filament is a collection of full-stack components for accelerated Laravel development. From 3.0.0 until 3.3.52, 4.11.5, and 5.6.5, any schema can contain a file upload form field, so Filament applies Livewire's WithFileUploads trait to the Livewire component the schema is embedded in. However, some schemas, such as the panel login form, do not require file uploads, and exposing unauthenticated temporary file uploads on these components is not an acceptable risk. On these components, an unauthenticated attacker could upload arbitrary files to the application's temporary storage, which could be abused to exhaust disk space or inflate storage costs. This vulnerability is fixed in 3.3.52, 4.11.5, and 5.6.5.
References
- GitHub advisory GHSA-44wp-g8f4-f4v5 github.com
Other filament/filament advisories
- medium CVE-2026-104181: Filament: Multi-factor authentication (app) management actions do not require password reauthentication 2026-10-05
- medium CVE-2026-84306: Filament: Multi-factor authentication (app) codes can still be used after a newer code has been used 2026-09-01
- low CVE-2026-84307: Filament: Password validity disclosure for accounts denied panel access on login page 2026-09-01
- high CVE-2026-77567: Filament: Multi-factor authentication (app) can be bypassed when recovery codes are enabled 2026-09-01
- high CVE-2026-48505: Filament: Multi-factor authentication (app) recovery codes can still be used multiple times via concurrent submission 2026-06-25
- medium CVE-2026-48166: Filament: Timing-based user enumeration on login page 2026-06-23
Related
Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.
Ask about a fixWhere this data comes from
- Affected and fixed versions: the Packagist security advisories API (GitHub Advisory Database and FriendsOfPHP), the same data
composer audituses. Synced 2026-11-03. - Description, score, weakness and references: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Exploited-in-the-wild status: the CISA Known Exploited Vulnerabilities catalog, checked 2026-11-04.
- Compiled by Daniel Lasek at Laskyr from the sources above. The summary, “who can exploit it”, “how to fix it” and hardening sections are our plain-English reading of the record and are generated from it. The quoted description is the record's own text. Spot an error? Tell us.