Skip to content
Laskyr

filament/filament security advisory

CVE-2026-48166: Filament: Timing-based user enumeration on login page

CVE-2026-48166 is a medium-severity user enumeration vulnerability in the PHP package filament/filament (CVSS 5.3), published 22 June 2026. The advisory does not name a fixed version. It can be exploited without an account.

medium 5.3 published 2026-06-22 · updated 2026-10-25

The advisory does not name a fixed version

This user enumeration issue affects filament/filament in 2 release lines: >= 4.0.0, <= 4.11.4; >= 5.0.0, <= 5.6.4. The newest release (5.11.1) is outside the affected range.

Affected versions
>= 4.0.0, <= 4.11.4
>= 5.0.0, <= 5.6.4
Fixed in
not stated
Newest release
5.11.1
Severity
Medium · CVSS 5.3
Type
User enumeration
CWE-208
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your filament/filament version affected?

Run composer show filament/filament in your project, then enter the version. We check it against this and every other known filament/filament advisory.

Who can exploit CVE-2026-48166

CVSS vector (scored by GitHub): CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Your app is only exposed if it uses the affected part of filament/filament. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-48166 in filament/filament

  1. Find the installed version: composer show filament/filament. If you never required it yourself, composer why filament/filament shows which package pulls it in.
  2. Update it: composer update filament/filament --with-all-dependencies.
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "filament/filament": "^5.11.1" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-48166.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for user enumeration issues while the upgrade waits. None of it replaces the fix.

The CVE-2026-48166 advisory

Filament is a collection of full-stack components for accelerated Laravel development. From 4.0.0 until 4.11.5 and 5.6.5, the login page has an observable timing discrepancy that allows unauthenticated attackers to enumerate registered email addresses. The impact is limited to disclosing whether an account exists for a given email. This vulnerability is fixed in 4.11.5 and 5.6.5.

Description from the CVE record, published by GitHub (the CVE Numbering Authority), via the NVD entry for CVE-2026-48166. Advisory title: “Filament: Timing-based user enumeration on login page”.

References

Other filament/filament advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit