Skip to content
Laskyr

filament/filament security advisory

CVE-2026-84306: Filament: Multi-factor authentication (app) codes can still be used after a newer code has been used

CVE-2026-84306 is a medium-severity security vulnerability in the PHP package filament/filament (CVSS 6.5), published 1 September 2026. It is fixed in 4.12.6 and 5.7.6, one per release line; earlier versions on each line are affected. It can be exploited without an account.

medium 6.5 published 2026-09-01 · updated 2026-09-09

Fixed in filament/filament 4.12.6 and 5.7.6

This security issue affects filament/filament in 2 release lines: >= 4.0.0, < 4.12.6; >= 5.0.0, < 5.7.6. Upgrade to the fixed version for your release line (4.12.6 and 5.7.6). The newest release, 5.11.1, is not affected.

Affected versions
>= 4.0.0, < 4.12.6
>= 5.0.0, < 5.7.6
Fixed in
4.12.6, 5.7.6
Newest release
5.11.1
Severity
Medium · CVSS 6.5
Type
Security issue
CWE-294
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your filament/filament version affected?

Run composer show filament/filament in your project, then enter the version. We check it against this and every other known filament/filament advisory.

Who can exploit CVE-2026-84306

CVSS vector (scored by GitHub): CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:L/A:N

Your app is only exposed if it uses the affected part of filament/filament. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-84306 in filament/filament

  1. Find the installed version: composer show filament/filament. If you never required it yourself, composer why filament/filament shows which package pulls it in.
  2. Update it: composer update filament/filament --with-all-dependencies. You need the fixed version for your release line (4.12.6 and 5.7.6).
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "filament/filament": "^5.7.6" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-84306.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for this kind of issue while the upgrade waits. None of it replaces the fix.

The CVE-2026-84306 advisory

Filament is a collection of full-stack components for accelerated Laravel development. From 4.0.0 until 4.12.6 and 5.7.6, packages/panels/src/Auth/MultiFactor/App/AppAuthentication.php uses AppAuthentication::verifyCode() with a used-code cache key derived from both the app authentication secret and the submitted TOTP code. This isolates the newest accepted timestep by code instead of by secret, allowing a previously issued app-based MFA code to be accepted after a newer code has already been used. Reuse of the exact same code was already prevented, but another code inside the accepted time window remained usable. An attacker who obtains the target account's password and one app-based MFA code can use that code for the remainder of the configured window, which is approximately four minutes with the default settings, even after the legitimate account holder logs in with a newer code. Email-based MFA is not affected. This issue is fixed in versions 4.12.6 and 5.7.6.

Description from the CVE record, published by GitHub (the CVE Numbering Authority), via the NVD entry for CVE-2026-84306. Advisory title: “Filament: Multi-factor authentication (app) codes can still be used after a newer code has been used”.

References

Other filament/filament advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit