Skip to content
Laskyr

filament/filament security advisory

CVE-2026-48505: Filament: Multi-factor authentication (app) recovery codes can still be used multiple times via concurrent submission

CVE-2026-48505 is a high-severity security vulnerability in the PHP package filament/filament (CVSS 7.4), published 22 June 2026. It is fixed in 4.11.5 and 5.6.5, one per release line; earlier versions on each line are affected. It can be exploited without an account.

high 7.4 published 2026-06-22 · updated 2026-10-25

Fixed in filament/filament 4.11.5 and 5.6.5

This security issue affects filament/filament in 2 release lines: >= 4.0.0, < 4.11.5; >= 5.0.0, < 5.6.5. Upgrade to the fixed version for your release line (4.11.5 and 5.6.5). The newest release, 5.11.1, is not affected.

Affected versions
>= 4.0.0, < 4.11.5
>= 5.0.0, < 5.6.5
Fixed in
4.11.5, 5.6.5
Newest release
5.11.1
Severity
High · CVSS 7.4
Type
Security issue
CWE-362, CWE-841
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your filament/filament version affected?

Run composer show filament/filament in your project, then enter the version. We check it against this and every other known filament/filament advisory.

Who can exploit CVE-2026-48505

CVSS vector (scored by GitHub): CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N

Your app is only exposed if it uses the affected part of filament/filament. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-48505 in filament/filament

  1. Find the installed version: composer show filament/filament. If you never required it yourself, composer why filament/filament shows which package pulls it in.
  2. Update it: composer update filament/filament --with-all-dependencies. You need the fixed version for your release line (4.11.5 and 5.6.5).
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "filament/filament": "^5.6.5" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-48505.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for this kind of issue while the upgrade waits. None of it replaces the fix.

The CVE-2026-48505 advisory

Filament is a collection of full-stack components for accelerated Laravel development. From 4.0.0 until 4.11.5 and 5.6.5, a flaw in the handling of recovery codes for app-based multi-factor authentication allows the same recovery code to be reused via concurrent submission. This issue does not affect email-based MFA. It also only applies when recovery codes are enabled. If an attacker gains access to both the user's password and their recovery codes, they get two authenticated sessions per recovery code burned instead of one, or more if they batch the parallel submissions wider, materially extending the attacker's window of access compared to what the single-use guarantee implies. This vulnerability is fixed in 4.11.5 and 5.6.5.

Description from the CVE record, published by GitHub (the CVE Numbering Authority), via the NVD entry for CVE-2026-48505. Advisory title: “Filament: Multi-factor authentication (app) recovery codes can still be used multiple times via concurrent submission”.

References

Other filament/filament advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit