Skip to content
Laskyr

drupal/core security advisory

CVE-2026-9082: Drupal Core has a SQL Injection issue

CVE-2026-9082 is a critical-severity SQL injection vulnerability in the PHP package drupal/core (CVSS 9.8), published 20 May 2026. It is fixed in 10.4.10, 10.5.10, 10.6.9, 11.1.10, 11.2.12 and 11.3.10, one per release line; earlier versions on each line are affected. It can be exploited without an account. CISA lists it as exploited in the wild since 22 May 2026.

critical 9.8 exploited in the wild published 2026-05-20 · updated 2026-10-07

Fixed in drupal/core 10.4.10, 10.5.10, 10.6.9, 11.1.10, 11.2.12 and 11.3.10

This SQL injection issue affects drupal/core in 6 release lines: >= 8.9.0, < 10.4.10; >= 10.5.0, < 10.5.10; >= 10.6.0, < 10.6.9; >= 11.0.0, < 11.1.10; >= 11.2.0, < 11.2.12; >= 11.3.0, < 11.3.10. Upgrade to the fixed version for your release line (10.4.10, 10.5.10, 10.6.9, 11.1.10, 11.2.12 and 11.3.10). The newest release, 11.4.11, is not affected.

Affected versions
>= 8.9.0, < 10.4.10
>= 10.5.0, < 10.5.10
>= 10.6.0, < 10.6.9
>= 11.0.0, < 11.1.10
>= 11.2.0, < 11.2.12
>= 11.3.0, < 11.3.10
Fixed in
10.4.10, 10.5.10, 10.6.9, 11.1.10, 11.2.12, 11.3.10
Newest release
11.4.11
Severity
Critical · CVSS 9.8
Type
SQL injection
CWE-89
Exploited in the wild
Yes: on the CISA KEV list since 2026-05-22

Is your drupal/core version affected?

Run composer show drupal/core in your project, then enter the version. We check it against this and every other known drupal/core advisory.

Who can exploit CVE-2026-9082

CVSS vector (scored by Drupal): CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Your app is only exposed if it uses the affected part of drupal/core. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-9082 in drupal/core

  1. Find the installed version: composer show drupal/core. If you never required it yourself, composer why drupal/core shows which package pulls it in.
  2. Update it: composer update drupal/core --with-all-dependencies. You need the fixed version for your release line (10.4.10, 10.5.10, 10.6.9, 11.1.10, 11.2.12 and 11.3.10).
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "drupal/core": "^11.3.10" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-9082.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for SQL injection issues while the upgrade waits. None of it replaces the fix.

The CVE-2026-9082 advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Drupal Drupal core allows SQL Injection. This issue affects Drupal core: from 8.9.0 before 10.4.10, from 10.5.0 before 10.5.10, from 10.6.0 before 10.6.9, from 11.0.0 before 11.1.10, from 11.2.0 before 11.2.12, from 11.3.0 before 11.3.10.

Description from the CVE record, published by Drupal (the CVE Numbering Authority), via the NVD entry for CVE-2026-9082. Advisory title: “Drupal Core has a SQL Injection issue”.

References

Other drupal/core advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit