drupal/core security advisory
CVE-2026-6366: Drupal core allows Object Injection
CVE-2026-6366 is a medium-severity PHP object injection vulnerability in the PHP package drupal/core (CVSS 6.6), published 19 May 2026. It is fixed in 10.5.9, 10.6.7, 11.2.11 and 11.3.7, one per release line; earlier versions on each line are affected. Exploiting it needs an admin-level account.
medium 6.6 published 2026-05-19 · updated 2026-07-24
- Affected versions
- >= 8.0.0, < 10.5.9
>= 10.6.0, < 10.6.7
>= 11.0.0, < 11.2.11
>= 11.3.0, < 11.3.7 - Fixed in
- 10.5.9, 10.6.7, 11.2.11, 11.3.7
- Newest release
- 11.4.11
- Severity
- Medium · CVSS 6.6
- Type
- PHP object injection
CWE-915 - Exploited in the wild
- Not on the CISA KEV list
checked 2026-11-04
Is your drupal/core version affected?
Who can exploit CVE-2026-6366
- Access: A high-privilege account in the app, such as an admin.
- Conditions: It only works under specific conditions the attacker does not fully control (CVSS rates the attack as high complexity).
CVSS vector (scored by CISA ADP): CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H
How to fix CVE-2026-6366 in drupal/core
- Find the installed version:
composer show drupal/core. If you never required it yourself,composer why drupal/coreshows which package pulls it in. - Update it:
composer update drupal/core --with-all-dependencies. You need the fixed version for your release line (10.5.9, 10.6.7, 11.2.11 and 11.3.7). - If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example
"drupal/core": "^11.3.7"if you can take that version), or upgrade the package that requires it. - Run
composer audit. It reads the same advisory data and should no longer list CVE-2026-6366. - Commit composer.lock and deploy it. On the server, run
composer install --no-devfrom the lock file, notcomposer update.
If you cannot upgrade yet
- Never pass user-controlled data to unserialize() or to template rendering, and restrict who can edit templates or settings.
- Put a web application firewall in front of the app and watch for new PHP files or admin users.
- If your app does not use the affected feature, note that in your audit, but still plan the upgrade.
The CVE-2026-6366 advisory
Improperly Controlled Modification of Dynamically-Determined Object Attributes vulnerability in Drupal Drupal core allows Object Injection. This issue affects Drupal core: from 8.0.0 before 10.5.9, from 10.6.0 before 10.6.7, from 11.0.0 before 11.2.11, from 11.3.0 before 11.3.7.
References
- GitHub advisory GHSA-xmjc-63pr-2mpg github.com
- drupal.org www.drupal.org
Other drupal/core advisories
- critical CVE-2026-9082: Drupal Core has a SQL Injection issue 2026-05-20
- medium CVE-2026-6365: Drupal core is Vulnerable to Cross-Site Scripting 2026-05-20
- medium CVE-2026-6367: Drupal core allows Cross-Site Scripting (XSS) 2026-05-20
- medium CVE-2025-13081: Drupal core allows Object Injection 2025-11-18
- low CVE-2025-13082: Drupal core allows Content Spoofing 2025-11-18
- low CVE-2025-13083: Drupal core allows Exploiting Incorrectly Configured Access Control Security Levels 2025-11-18
Related
Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.
Ask about a fixWhere this data comes from
- Affected and fixed versions: the Packagist security advisories API (GitHub Advisory Database and FriendsOfPHP), the same data
composer audituses. Synced 2026-11-03. - Description, score, weakness and references: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Exploited-in-the-wild status: the CISA Known Exploited Vulnerabilities catalog, checked 2026-11-04.
- Compiled by Daniel Lasek at Laskyr from the sources above. The summary, “who can exploit it”, “how to fix it” and hardening sections are our plain-English reading of the record and are generated from it. The quoted description is the record's own text. Spot an error? Tell us.