drupal/core security advisory
CVE-2025-13083: Drupal core allows Exploiting Incorrectly Configured Access Control Security Levels
CVE-2025-13083 is a low-severity information disclosure vulnerability in the PHP package drupal/core (CVSS 3.7), published 18 November 2025. It is fixed in 7.103, 10.4.9, 10.5.6, 11.1.9 and 11.2.8, one per release line; earlier versions on each line are affected. It can be exploited without an account.
low 3.7 published 2025-11-18 · updated 2026-10-18
- Affected versions
- >= 7.0, < 7.103
>= 8.0.0, < 10.4.9
>= 10.5.0, < 10.5.6
>= 11.0.0, < 11.1.9
>= 11.2.0, < 11.2.8 - Fixed in
- 7.103, 10.4.9, 10.5.6, 11.1.9, 11.2.8
- Newest release
- 11.4.11
- Severity
- Low · CVSS 3.7
- Type
- Information disclosure
CWE-525 - Exploited in the wild
- Not on the CISA KEV list
checked 2026-11-04
Is your drupal/core version affected?
Who can exploit CVE-2025-13083
- Access: No account. Anyone who can send a request to an app that uses the affected code.
- Conditions: It only works under specific conditions the attacker does not fully control (CVSS rates the attack as high complexity).
CVSS vector (scored by CISA ADP): CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
How to fix CVE-2025-13083 in drupal/core
- Find the installed version:
composer show drupal/core. If you never required it yourself,composer why drupal/coreshows which package pulls it in. - Update it:
composer update drupal/core --with-all-dependencies. You need the fixed version for your release line (7.103, 10.4.9, 10.5.6, 11.1.9 and 11.2.8). - If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example
"drupal/core": "^11.2.8"if you can take that version), or upgrade the package that requires it. - Run
composer audit. It reads the same advisory data and should no longer list CVE-2025-13083. - Commit composer.lock and deploy it. On the server, run
composer install --no-devfrom the lock file, notcomposer update.
If you cannot upgrade yet
- Make sure APP_DEBUG (or your framework's debug mode) is off in production and error pages show no stack traces.
- If your app does not use the affected feature, note that in your audit, but still plan the upgrade.
The CVE-2025-13083 advisory
Use of Web Browser Cache Containing Sensitive Information vulnerability in Drupal Drupal core allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Drupal core: from 8.0.0 before 10.4.9, from 10.5.0 before 10.5.6, from 11.0.0 before 11.1.9, from 11.2.0 before 11.2.8, from 7.0 before 7.103.
References
- GitHub advisory GHSA-mhpg-hpj5-73r2 github.com
- drupal.org www.drupal.org
Other drupal/core advisories
- critical CVE-2026-9082: Drupal Core has a SQL Injection issue 2026-05-20
- medium CVE-2026-6366: Drupal core allows Object Injection 2026-05-20
- medium CVE-2026-6365: Drupal core is Vulnerable to Cross-Site Scripting 2026-05-20
- medium CVE-2026-6367: Drupal core allows Cross-Site Scripting (XSS) 2026-05-20
- medium CVE-2025-13081: Drupal core allows Object Injection 2025-11-18
- low CVE-2025-13082: Drupal core allows Content Spoofing 2025-11-18
Related
Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.
Ask about a fixWhere this data comes from
- Affected and fixed versions: the Packagist security advisories API (GitHub Advisory Database and FriendsOfPHP), the same data
composer audituses. Synced 2026-11-03. - Description, score, weakness and references: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Exploited-in-the-wild status: the CISA Known Exploited Vulnerabilities catalog, checked 2026-11-04.
- Compiled by Daniel Lasek at Laskyr from the sources above. The summary, “who can exploit it”, “how to fix it” and hardening sections are our plain-English reading of the record and are generated from it. The quoted description is the record's own text. Spot an error? Tell us.