Skip to content
Laskyr

drupal/core security advisory

CVE-2025-13081: Drupal core allows Object Injection

CVE-2025-13081 is a medium-severity PHP object injection vulnerability in the PHP package drupal/core (CVSS 5.9), published 18 November 2025. It is fixed in 10.4.9, 10.5.6, 11.1.9 and 11.2.8, one per release line; earlier versions on each line are affected. Exploiting it needs an admin-level account.

medium 5.9 published 2025-11-18 · updated 2026-10-18

Fixed in drupal/core 10.4.9, 10.5.6, 11.1.9 and 11.2.8

This PHP object injection issue affects drupal/core in 4 release lines: >= 8.0.0, < 10.4.9; >= 10.5.0, < 10.5.6; >= 11.0.0, < 11.1.9; >= 11.2.0, < 11.2.8. Upgrade to the fixed version for your release line (10.4.9, 10.5.6, 11.1.9 and 11.2.8). The newest release, 11.4.11, is not affected.

Affected versions
>= 8.0.0, < 10.4.9
>= 10.5.0, < 10.5.6
>= 11.0.0, < 11.1.9
>= 11.2.0, < 11.2.8
Fixed in
10.4.9, 10.5.6, 11.1.9, 11.2.8
Newest release
11.4.11
Severity
Medium · CVSS 5.9
Type
PHP object injection
CWE-915, CWE-502
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your drupal/core version affected?

Run composer show drupal/core in your project, then enter the version. We check it against this and every other known drupal/core advisory.

Who can exploit CVE-2025-13081

CVSS vector (scored by CISA ADP): CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:N

Your app is only exposed if it uses the affected part of drupal/core. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2025-13081 in drupal/core

  1. Find the installed version: composer show drupal/core. If you never required it yourself, composer why drupal/core shows which package pulls it in.
  2. Update it: composer update drupal/core --with-all-dependencies. You need the fixed version for your release line (10.4.9, 10.5.6, 11.1.9 and 11.2.8).
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "drupal/core": "^11.2.8" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2025-13081.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for PHP object injection issues while the upgrade waits. None of it replaces the fix.

The CVE-2025-13081 advisory

Improperly Controlled Modification of Dynamically-Determined Object Attributes vulnerability in Drupal Drupal core allows Object Injection.This issue affects Drupal core: from 8.0.0 before 10.4.9, from 10.5.0 before 10.5.6, from 11.0.0 before 11.1.9, from 11.2.0 before 11.2.8.

Description from the CVE record, published by Drupal (the CVE Numbering Authority), via the NVD entry for CVE-2025-13081. Advisory title: “Drupal core allows Object Injection”.

References

Other drupal/core advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit