Skip to content
Laskyr

drupal/core security advisory

CVE-2026-6367: Drupal core allows Cross-Site Scripting (XSS)

CVE-2026-6367 is a medium-severity XSS vulnerability in the PHP package drupal/core (CVSS 6.1), published 19 May 2026. It is fixed in 11.3.7; earlier versions are affected. It can be exploited without an account.

medium 6.1 published 2026-05-19 · updated 2026-07-24

Fixed in drupal/core 11.3.7

This XSS issue affects drupal/core versions >= 11.3.0, < 11.3.7. Upgrade to the fixed version for your release line (11.3.7). The newest release, 11.4.11, is not affected.

Affected versions
>= 11.3.0, < 11.3.7
Fixed in
11.3.7
Newest release
11.4.11
Severity
Medium · CVSS 6.1
Type
Cross-site scripting (XSS)
CWE-79
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your drupal/core version affected?

Run composer show drupal/core in your project, then enter the version. We check it against this and every other known drupal/core advisory.

Who can exploit CVE-2026-6367

CVSS vector (scored by CISA ADP): CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Your app is only exposed if it uses the affected part of drupal/core. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-6367 in drupal/core

  1. Find the installed version: composer show drupal/core. If you never required it yourself, composer why drupal/core shows which package pulls it in.
  2. Update it: composer update drupal/core --with-all-dependencies. You need 11.3.7 or newer.
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "drupal/core": "^11.3.7" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-6367.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for XSS issues while the upgrade waits. None of it replaces the fix.

The CVE-2026-6367 advisory

Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal Drupal core allows Cross-Site Scripting (XSS). This issue affects Drupal core: from 11.3.0 before 11.3.7.

Description from the CVE record, published by Drupal (the CVE Numbering Authority), via the NVD entry for CVE-2026-6367. Advisory title: “Drupal core allows Cross-Site Scripting (XSS)”.

References

Other drupal/core advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit