Skip to content
Laskyr

craftcms/cms security advisory

CVE-2026-72778: Craft CMS: Authenticated RCE via condition.config JSON cleanse bypass

CVE-2026-72778 is a high-severity remote code execution vulnerability in the PHP package craftcms/cms (CVSS 8.8), published 11 August 2026. It is fixed in 4.18.2 and 5.10.6, one per release line; earlier versions on each line are affected. Exploiting it needs a low-privilege user account.

high 8.8 published 2026-08-11 · updated 2026-10-24

Fixed in craftcms/cms 4.18.2 and 5.10.6

This remote code execution issue affects craftcms/cms in 2 release lines: >= 4.0.0-RC1, < 4.18.2; >= 5.0.0-RC1, < 5.10.6. Upgrade to the fixed version for your release line (4.18.2 and 5.10.6). The newest release, 5.12.0, is not affected.

Affected versions
>= 4.0.0-RC1, < 4.18.2
>= 5.0.0-RC1, < 5.10.6
Fixed in
4.18.2, 5.10.6
Newest release
5.12.0
Severity
High · CVSS 8.8
Type
Remote code execution
CWE-915
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your craftcms/cms version affected?

Run composer show craftcms/cms in your project, then enter the version. We check it against this and every other known craftcms/cms advisory.

Who can exploit CVE-2026-72778

CVSS vector (scored by VulnCheck): CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Your app is only exposed if it uses the affected part of craftcms/cms. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-72778 in craftcms/cms

  1. Find the installed version: composer show craftcms/cms. If you never required it yourself, composer why craftcms/cms shows which package pulls it in.
  2. Update it: composer update craftcms/cms --with-all-dependencies. You need the fixed version for your release line (4.18.2 and 5.10.6).
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "craftcms/cms": "^5.10.6" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-72778.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for remote code execution issues while the upgrade waits. None of it replaces the fix.

The CVE-2026-72778 advisory

Craft CMS versions from 4.0.0-RC1 before 4.18.2 and from 5.0.0-RC1 before 5.10.6 contain an authenticated remote code execution vulnerability in the control panel element-search condition handling. Craft cleanses the outer request-controlled condition array via Component::cleanseConfig(), but Conditions::createCondition() later decodes and merges the JSON string in condition.config without re-running cleanseConfig() on the decoded configuration. Because condition.config is a JSON string during the first cleanse, Yii special config keys such as 'as ...' and 'on ...' can be hidden inside it and, after JSON decoding, are interpreted by Yii as behavior/event configuration during FieldLayout object creation. An attacker with an authenticated control panel session (and a valid CSRF token) can exploit this to execute operating system commands as the PHP/web user.

Description from the CVE record, published by VulnCheck (the CVE Numbering Authority), via the NVD entry for CVE-2026-72778. Advisory title: “Craft CMS: Authenticated RCE via condition.config JSON cleanse bypass”.

References

Other craftcms/cms advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit