Skip to content
Laskyr

craftcms/cms security advisory

CVE-2026-72785: Craft CMS: Authorization bypass: view-only Categories user can modify category structure via structures/move-element

CVE-2026-72785 is a medium-severity missing authorization vulnerability in the PHP package craftcms/cms (CVSS 4.3), published 11 August 2026. It is fixed in 5.10.6; earlier versions are affected. Exploiting it needs a low-privilege user account.

medium 4.3 published 2026-08-11 · updated 2026-10-24

Fixed in craftcms/cms 5.10.6

This missing authorization issue affects craftcms/cms versions >= 5.0.0-RC1, < 5.10.6. Upgrade to the fixed version for your release line (5.10.6). The newest release, 5.12.0, is not affected.

Affected versions
>= 5.0.0-RC1, < 5.10.6
Fixed in
5.10.6
Newest release
5.12.0
Severity
Medium · CVSS 4.3
Type
Missing authorization check
CWE-863
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your craftcms/cms version affected?

Run composer show craftcms/cms in your project, then enter the version. We check it against this and every other known craftcms/cms advisory.

Who can exploit CVE-2026-72785

CVSS vector (scored by VulnCheck): CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N

Your app is only exposed if it uses the affected part of craftcms/cms. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-72785 in craftcms/cms

  1. Find the installed version: composer show craftcms/cms. If you never required it yourself, composer why craftcms/cms shows which package pulls it in.
  2. Update it: composer update craftcms/cms --with-all-dependencies. You need 5.10.6 or newer.
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "craftcms/cms": "^5.10.6" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-72785.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for missing authorization issues while the upgrade waits. None of it replaces the fix.

The CVE-2026-72785 advisory

Craft CMS 5.0.0-RC1 through 5.10.5 contains an incorrect authorization vulnerability. A control-panel user holding only the viewCategories permission (without saveCategories) for a category group can permanently modify that group's category structure — reordering and re-parenting categories — via the structures/move-element action. The structureEditable flag is computed from the view permission rather than the save permission, and the StructuresController authorizes the mutating action on that read-time session grant without a save re-check. Because a category's URI is derived from its position in the structure, moving a category changes its URL and those of its descendants and can corrupt navigation menus built from the category taxonomy. The issue is fixed in 5.10.6.

Description from the CVE record, published by VulnCheck (the CVE Numbering Authority), via the NVD entry for CVE-2026-72785. Advisory title: “Craft CMS: Authorization bypass: view-only Categories user can modify category structure via structures/move-element”.

References

Other craftcms/cms advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit