craftcms/cms security advisory
CVE-2026-72779: Craft CMS: Arbitrary file read via SplFileObject in non-sandboxed template contexts
CVE-2026-72779 is a medium-severity path traversal vulnerability in the PHP package craftcms/cms (CVSS 4.5), published 11 August 2026. It is fixed in 4.18.2 and 5.10.6, one per release line; earlier versions on each line are affected. Exploiting it needs an admin-level account.
medium 4.5 published 2026-08-11 · updated 2026-10-24
- Affected versions
- >= 4.0.0-RC1, < 4.18.2
>= 5.0.0-RC1, < 5.10.6 - Fixed in
- 4.18.2, 5.10.6
- Newest release
- 5.12.0
- Severity
- Medium · CVSS 4.5
- Type
- Path traversal / file read
CWE-184 - Exploited in the wild
- Not on the CISA KEV list
checked 2026-11-04
Is your craftcms/cms version affected?
Who can exploit CVE-2026-72779
- Access: A high-privilege account in the app, such as an admin.
- Interaction: A user also has to do something, such as open a link or a page the attacker prepared.
CVSS vector (scored by VulnCheck): CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:N/A:N
How to fix CVE-2026-72779 in craftcms/cms
- Find the installed version:
composer show craftcms/cms. If you never required it yourself,composer why craftcms/cmsshows which package pulls it in. - Update it:
composer update craftcms/cms --with-all-dependencies. You need the fixed version for your release line (4.18.2 and 5.10.6). - If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example
"craftcms/cms": "^5.10.6"if you can take that version), or upgrade the package that requires it. - Run
composer audit. It reads the same advisory data and should no longer list CVE-2026-72779. - Commit composer.lock and deploy it. On the server, run
composer install --no-devfrom the lock file, notcomposer update.
If you cannot upgrade yet
- Validate file names against an allow-list and reject paths containing ../ or absolute paths.
- If your app does not use the affected feature, note that in your audit, but still plan the upgrade.
The CVE-2026-72779 advisory
Craft CMS 5.0.0-RC1 before 5.10.6 and 4.0.0-RC1 before 4.18.2 contain an arbitrary file read vulnerability. The create() Twig function restricts class instantiation using a 5-entry blocklist that does not include SplFileObject, allowing an authenticated administrator (with allowAdminChanges=true) to configure a malicious entry type title or URI format that instantiates SplFileObject in a non-sandboxed template context. When a user subsequently creates an entry in the affected section, arbitrary files on the server (such as .env containing the security key and database credentials) are read and rendered as entry titles.
References
- GitHub advisory GHSA-957r-qf9p-67xw github.com
- Vulncheck security advisory www.vulncheck.com
Other craftcms/cms advisories
- critical Craft CMS: Passkey login accepts replayed WebAuthn assertions 2026-08-07
- medium CVE-2026-72782: Craft CMS: Authenticated leak of secret environment variables 2026-08-06
- medium CVE-2026-72785: Craft CMS: Authorization bypass: view-only Categories user can modify category structure via structures/move-element 2026-08-06
- medium CVE-2026-14794: Craft CMS: Missing authorization check allows non-admin control panel users access to user registration metrics 2026-08-06
- low CVE-2026-72783: Craft CMS: Incorrect path validation could potentially lead to path traversal 2026-08-06
- medium Craft CMS: Stored XSS in the control panel via unescaped draft name 2026-08-06
Related
Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.
Ask about a fixWhere this data comes from
- Affected and fixed versions: the Packagist security advisories API (GitHub Advisory Database and FriendsOfPHP), the same data
composer audituses. Synced 2026-11-03. - Description, score, weakness and references: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Exploited-in-the-wild status: the CISA Known Exploited Vulnerabilities catalog, checked 2026-11-04.
- Compiled by Daniel Lasek at Laskyr from the sources above. The summary, “who can exploit it”, “how to fix it” and hardening sections are our plain-English reading of the record and are generated from it. The quoted description is the record's own text. Spot an error? Tell us.