Skip to content
Laskyr

craftcms/cms security advisory

CVE-2026-72783: Craft CMS: Incorrect path validation could potentially lead to path traversal

CVE-2026-72783 is a low-severity path traversal vulnerability in the PHP package craftcms/cms (CVSS 6.2), published 11 August 2026. It is fixed in 4.18.2 and 5.10.6, one per release line; earlier versions on each line are affected. It can be exploited without an account.

low 6.2 published 2026-08-11 · updated 2026-10-24

Fixed in craftcms/cms 4.18.2 and 5.10.6

This path traversal issue affects craftcms/cms in 2 release lines: >= 4.0.0-RC1, < 4.18.2; >= 5.0.0-RC1, < 5.10.6. Upgrade to the fixed version for your release line (4.18.2 and 5.10.6). The newest release, 5.12.0, is not affected.

Affected versions
>= 4.0.0-RC1, < 4.18.2
>= 5.0.0-RC1, < 5.10.6
Fixed in
4.18.2, 5.10.6
Newest release
5.12.0
Severity
Low · CVSS 6.2
Type
Path traversal / file read
CWE-22
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your craftcms/cms version affected?

Run composer show craftcms/cms in your project, then enter the version. We check it against this and every other known craftcms/cms advisory.

Who can exploit CVE-2026-72783

CVSS vector (scored by VulnCheck): CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Your app is only exposed if it uses the affected part of craftcms/cms. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-72783 in craftcms/cms

  1. Find the installed version: composer show craftcms/cms. If you never required it yourself, composer why craftcms/cms shows which package pulls it in.
  2. Update it: composer update craftcms/cms --with-all-dependencies. You need the fixed version for your release line (4.18.2 and 5.10.6).
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "craftcms/cms": "^5.10.6" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-72783.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for path traversal issues while the upgrade waits. None of it replaces the fix.

The CVE-2026-72783 advisory

Craft CMS versions >= 5.0.0-RC1 before 5.10.6 and >= 4.0.0-RC1 before 4.18.2 contain a theoretical path traversal weakness in the ensurePathIsContained function of the Local file system class. The order of operations validates the path before normalization, so normalization could invalidate prior validation assumptions (a desanitization-style issue) and potentially resolve to files outside the intended volume directory. The vendor notes the issue is not directly exploitable and no exploitable scenario has been discovered; the fix is recommended for hardening.

Description from the CVE record, published by VulnCheck (the CVE Numbering Authority), via the NVD entry for CVE-2026-72783. Advisory title: “Craft CMS: Incorrect path validation could potentially lead to path traversal”.

References

Other craftcms/cms advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit