craftcms/cms security advisory
CVE-2026-14794: Craft CMS: Missing authorization check allows non-admin control panel users access to user registration metrics
CVE-2026-14794 is a medium-severity missing authorization vulnerability in the PHP package craftcms/cms (CVSS 4.3), published 6 July 2026. It is fixed in 4.18.1 and 5.10.3, one per release line; earlier versions on each line are affected. Exploiting it needs a low-privilege user account.
medium 4.3 published 2026-07-06 · updated 2026-10-25
- Affected versions
- >= 4.0.0-RC1, < 4.18.1
>= 5.0.0-RC1, < 5.10.3 - Fixed in
- 4.18.1, 5.10.3
- Newest release
- 5.12.0
- Severity
- Medium · CVSS 4.3
- Type
- Missing authorization check
CWE-266, CWE-285 - Exploited in the wild
- Not on the CISA KEV list
checked 2026-11-04
Is your craftcms/cms version affected?
Who can exploit CVE-2026-14794
- Access: A normal, low-privilege user account in the app.
CVSS vector (scored by VulDB): CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
How to fix CVE-2026-14794 in craftcms/cms
- Find the installed version:
composer show craftcms/cms. If you never required it yourself,composer why craftcms/cmsshows which package pulls it in. - Update it:
composer update craftcms/cms --with-all-dependencies. You need the fixed version for your release line (4.18.1 and 5.10.3). - If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example
"craftcms/cms": "^5.10.3"if you can take that version), or upgrade the package that requires it. - Run
composer audit. It reads the same advisory data and should no longer list CVE-2026-14794. - Commit composer.lock and deploy it. On the server, run
composer install --no-devfrom the lock file, notcomposer update.
If you cannot upgrade yet
- Remove accounts you do not need and review what each role can do.
- Put the admin area behind a VPN, IP allow-list or extra login until you upgrade.
- If your app does not use the affected feature, note that in your audit, but still plan the upgrade.
The CVE-2026-14794 advisory
A flaw has been found in Craft CMS up to 4.18.0.1. Affected by this vulnerability is the function actionGetNewUsersData of the file src/controllers/ChartsController.php of the component Charts Endpoint. This manipulation of the argument userGroupId causes improper authorization. The attack is possible to be carried out remotely. Upgrading to version 4.18.1 addresses this issue. Patch name: 9ee53efc1314e6aba32771c66a13e072a246f4ce. It is suggested to upgrade the affected component.
References
- GitHub advisory GHSA-rvmm-v933-jgxq github.com
- Vuldb security advisory vuldb.com
- Fix commit 9ee53ef github.com
- Release 4.18.1 github.com
- vuldb.com vuldb.com
- vuldb.com vuldb.com
- vuldb.com vuldb.com
Other craftcms/cms advisories
- critical Craft CMS: Passkey login accepts replayed WebAuthn assertions 2026-08-07
- medium CVE-2026-72779: Craft CMS: Arbitrary file read via SplFileObject in non-sandboxed template contexts 2026-08-06
- medium CVE-2026-72782: Craft CMS: Authenticated leak of secret environment variables 2026-08-06
- medium CVE-2026-72785: Craft CMS: Authorization bypass: view-only Categories user can modify category structure via structures/move-element 2026-08-06
- low CVE-2026-72783: Craft CMS: Incorrect path validation could potentially lead to path traversal 2026-08-06
- medium Craft CMS: Stored XSS in the control panel via unescaped draft name 2026-08-06
Related
Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.
Ask about a fixWhere this data comes from
- Affected and fixed versions: the Packagist security advisories API (GitHub Advisory Database and FriendsOfPHP), the same data
composer audituses. Synced 2026-11-03. - Description, score, weakness and references: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Exploited-in-the-wild status: the CISA Known Exploited Vulnerabilities catalog, checked 2026-11-04.
- Compiled by Daniel Lasek at Laskyr from the sources above. The summary, “who can exploit it”, “how to fix it” and hardening sections are our plain-English reading of the record and are generated from it. The quoted description is the record's own text. Spot an error? Tell us.