Skip to content
Laskyr

craftcms/cms security advisory

CVE-2026-56383: Craft CMS has Stored XSS in Table Field in its "Row Heading" Column Type

CVE-2026-56383 is a low-severity stored XSS vulnerability in the PHP package craftcms/cms (CVSS 4.8), published 21 June 2026. The advisory does not name a fixed version. Exploiting it needs an admin-level account.

low 4.8 published 2026-06-21 · updated 2026-10-25

The advisory does not name a fixed version

This stored XSS issue affects craftcms/cms in 2 release lines: >= 4.5.0-beta.1, <= 4.16.18; >= 5.0.0-RC1, <= 5.8.22. The newest release (5.12.0) is outside the affected range.

Affected versions
>= 4.5.0-beta.1, <= 4.16.18
>= 5.0.0-RC1, <= 5.8.22
Fixed in
not stated
Newest release
5.12.0
Severity
Low · CVSS 4.8
Type
Stored cross-site scripting (XSS)
CWE-79
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your craftcms/cms version affected?

Run composer show craftcms/cms in your project, then enter the version. We check it against this and every other known craftcms/cms advisory.

Who can exploit CVE-2026-56383

CVSS vector (scored by VulnCheck): CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N

Your app is only exposed if it uses the affected part of craftcms/cms. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-56383 in craftcms/cms

  1. Find the installed version: composer show craftcms/cms. If you never required it yourself, composer why craftcms/cms shows which package pulls it in.
  2. Update it: composer update craftcms/cms --with-all-dependencies.
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "craftcms/cms": "^5.12.0" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-56383.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for stored XSS issues while the upgrade waits. None of it replaces the fix.

The CVE-2026-56383 advisory

Craft CMS contains a stored cross-site scripting (XSS) vulnerability in the editableTable.twig component when using the 'Row Heading' column type. The application fails to sanitize input within row heading default values, allowing an attacker with an administrator account (with allowAdminChanges enabled) to inject arbitrary JavaScript that executes when another user views a page containing the affected table field. Affected versions are >= 4.5.0-beta.1 through 4.16.18 and >= 5.0.0-RC1 through 5.8.22; fixed in 4.16.19 and 5.8.23.

Description from the CVE record, published by VulnCheck (the CVE Numbering Authority), via the NVD entry for CVE-2026-56383. Advisory title: “Craft CMS has Stored XSS in Table Field in its "Row Heading" Column Type”.

References

Other craftcms/cms advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit