Skip to content
Laskyr

craftcms/cms security advisory

CVE-2026-56382: Craft CMS: RCE via missing cleanseConfig in FieldsController::actionRenderCardPreview

CVE-2026-56382 is a high-severity remote code execution vulnerability in the PHP package craftcms/cms (CVSS 7.2), published 21 June 2026. The advisory does not name a fixed version. Exploiting it needs an admin-level account.

high 7.2 published 2026-06-21 · updated 2026-10-25

The advisory does not name a fixed version

This remote code execution issue affects craftcms/cms versions >= 5.5.0, <= 5.9.13. The newest release (5.12.0) is outside the affected range.

Affected versions
>= 5.5.0, <= 5.9.13
Fixed in
not stated
Newest release
5.12.0
Severity
High · CVSS 7.2
Type
Remote code execution
CWE-94
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your craftcms/cms version affected?

Run composer show craftcms/cms in your project, then enter the version. We check it against this and every other known craftcms/cms advisory.

Who can exploit CVE-2026-56382

CVSS vector (scored by VulnCheck): CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Your app is only exposed if it uses the affected part of craftcms/cms. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-56382 in craftcms/cms

  1. Find the installed version: composer show craftcms/cms. If you never required it yourself, composer why craftcms/cms shows which package pulls it in.
  2. Update it: composer update craftcms/cms --with-all-dependencies.
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "craftcms/cms": "^5.12.0" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-56382.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for remote code execution issues while the upgrade waits. None of it replaces the fix.

The CVE-2026-56382 advisory

Craft CMS (composer package craftcms/cms) versions >= 5.5.0 and <= 5.9.13 contain a remote code execution vulnerability in the FieldsController::actionRenderCardPreview() method, which passes the fieldLayoutConfig POST parameter directly to Fields::createLayout() without calling Component::cleanseConfig(). An authenticated admin user can inject Yii2 event handlers (e.g., 'on init' keys) via the fieldLayoutConfig parameter to execute arbitrary PHP code and disclose sensitive information (such as environment variables containing database credentials and CRAFT_SECURITY_KEY). The issue is fixed in version 5.9.14.

Description from the CVE record, published by VulnCheck (the CVE Numbering Authority), via the NVD entry for CVE-2026-56382. Advisory title: “Craft CMS: RCE via missing cleanseConfig in FieldsController::actionRenderCardPreview”.

References

Other craftcms/cms advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit