Skip to content
Laskyr

craftcms/cms security advisory

CVE-2026-55794: Craft CMS: Potential authenticated Remote Code Execution via referrer redirect

CVE-2026-55794 is a high-severity remote code execution vulnerability in the PHP package craftcms/cms (CVSS 8.7), published 2 July 2026. It is fixed in 5.10.0; earlier versions are affected. Exploiting it needs a low-privilege user account.

high 8.7 published 2026-07-02 · updated 2026-10-25

Fixed in craftcms/cms 5.10.0

This remote code execution issue affects craftcms/cms versions >= 5.9.0, < 5.10.0. Upgrade to the fixed version for your release line (5.10.0). The newest release, 5.12.0, is not affected.

Affected versions
>= 5.9.0, < 5.10.0
Fixed in
5.10.0
Newest release
5.12.0
Severity
High · CVSS 8.7
Type
Remote code execution
CWE-94, CWE-1336
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your craftcms/cms version affected?

Run composer show craftcms/cms in your project, then enter the version. We check it against this and every other known craftcms/cms advisory.

Who can exploit CVE-2026-55794

CVSS vector (scored by GitHub): CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:L/SI:L/SA:L

Your app is only exposed if it uses the affected part of craftcms/cms. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-55794 in craftcms/cms

  1. Find the installed version: composer show craftcms/cms. If you never required it yourself, composer why craftcms/cms shows which package pulls it in.
  2. Update it: composer update craftcms/cms --with-all-dependencies. You need 5.10.0 or newer.
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "craftcms/cms": "^5.10.0" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-55794.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for remote code execution issues while the upgrade waits. None of it replaces the fix.

The CVE-2026-55794 advisory

Craft CMS is a content management system (CMS). In versions 5.9.0 and above prior to 5.10.0, control panel users with the ability to edit entries can execute unsandboxed Twig code via the HTTP Referrer header, potentially leading to authenticated RCE. The issue happens when a user is saving entries. Strings for a signed redirect URL are being compiled as a Twig template via renderObjectTemplate(), and while a sandboxed alternative already exists (renderSandboxedObjectTemplate()), it is not used in this case. This signed URL can be specified by users, as it is reflected in the “Referer” HTTP request header, which is under attacker control. This issue has been fixed in version 5.10.0.

Description from the CVE record, published by GitHub (the CVE Numbering Authority), via the NVD entry for CVE-2026-55794. Advisory title: “Craft CMS: Potential authenticated Remote Code Execution via referrer redirect”.

References

Other craftcms/cms advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit