Skip to content
Laskyr

craftcms/cms security advisory

CVE-2026-55790: Craft CMS: DOM XSS via GitHub issue title in CraftSupport widget

CVE-2026-55790 is a high-severity XSS vulnerability in the PHP package craftcms/cms (CVSS 7.4), published 1 July 2026. It is fixed in 4.17.15 and 5.9.22, one per release line; earlier versions on each line are affected. It can be exploited without an account.

high 7.4 published 2026-07-01 · updated 2026-10-25

Fixed in craftcms/cms 4.17.15 and 5.9.22

This XSS issue affects craftcms/cms in 2 release lines: >= 4.0.0-RC1, < 4.17.15; >= 5.0.0-RC1, < 5.9.22. Upgrade to the fixed version for your release line (4.17.15 and 5.9.22). The newest release, 5.12.0, is not affected.

Affected versions
>= 4.0.0-RC1, < 4.17.15
>= 5.0.0-RC1, < 5.9.22
Fixed in
4.17.15, 5.9.22
Newest release
5.12.0
Severity
High · CVSS 7.4
Type
Cross-site scripting (XSS)
CWE-79
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

The sources disagree on the fixed version. The CVE text names 4.17.16, while Packagist's advisory data, which composer audit checks, names 4.17.15 for the same release line. Upgrade to the higher of the two (4.17.16) to be safe by both.

Is your craftcms/cms version affected?

Run composer show craftcms/cms in your project, then enter the version. We check it against this and every other known craftcms/cms advisory.

Who can exploit CVE-2026-55790

CVSS vector (scored by GitHub): CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

Your app is only exposed if it uses the affected part of craftcms/cms. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-55790 in craftcms/cms

  1. Find the installed version: composer show craftcms/cms. If you never required it yourself, composer why craftcms/cms shows which package pulls it in.
  2. Update it: composer update craftcms/cms --with-all-dependencies. You need the fixed version for your release line (4.17.15 and 5.9.22).
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "craftcms/cms": "^5.9.22" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-55790.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for XSS issues while the upgrade waits. None of it replaces the fix.

The CVE-2026-55790 advisory

Craft CMS is a content management system (CMS). In versions 5.0.0-RC1 through 5.9.22 and 4.0.0-RC1 through 4.17.15, an attacker with only a GitHub account can plant a JavaScript payload in a craftcms/cms issue title. When a Craft admin uses the CraftSupport widget’s "Give feedback" screen and types a search term that returns the poisoned issue, the payload executes in the admin’s control panel session. No control panel account or elevated privileges are required on the attacker’s side. This issue has been fixed in versions 4.17.16 and 5.9.23.

Description from the CVE record, published by GitHub (the CVE Numbering Authority), via the NVD entry for CVE-2026-55790. Advisory title: “Craft CMS: DOM XSS via GitHub issue title in CraftSupport widget”.

References

Other craftcms/cms advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit