Skip to content
Laskyr

craftcms/cms security advisory

CVE-2026-50282: Craft CMS Vulnerable to Unauthorized Deletion of Destination Folders During Forced Moves

CVE-2026-50282 is a high-severity missing authorization vulnerability in the PHP package craftcms/cms (CVSS 4.9), published 2 July 2026. It is fixed in 4.17.14 and 5.9.21, one per release line; earlier versions on each line are affected. Exploiting it needs a low-privilege user account.

high 4.9 published 2026-07-02 · updated 2026-10-25

Fixed in craftcms/cms 4.17.14 and 5.9.21

This missing authorization issue affects craftcms/cms in 2 release lines: >= 4.0.0-RC1, < 4.17.14; >= 5.0.0-RC1, < 5.9.21. Upgrade to the fixed version for your release line (4.17.14 and 5.9.21). The newest release, 5.12.0, is not affected.

Affected versions
>= 4.0.0-RC1, < 4.17.14
>= 5.0.0-RC1, < 5.9.21
Fixed in
4.17.14, 5.9.21
Newest release
5.12.0
Severity
High · CVSS 4.9
Type
Missing authorization check
CWE-862
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your craftcms/cms version affected?

Run composer show craftcms/cms in your project, then enter the version. We check it against this and every other known craftcms/cms advisory.

Who can exploit CVE-2026-50282

CVSS vector (scored by GitHub): CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:U

Your app is only exposed if it uses the affected part of craftcms/cms. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-50282 in craftcms/cms

  1. Find the installed version: composer show craftcms/cms. If you never required it yourself, composer why craftcms/cms shows which package pulls it in.
  2. Update it: composer update craftcms/cms --with-all-dependencies. You need the fixed version for your release line (4.17.14 and 5.9.21).
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "craftcms/cms": "^5.9.21" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-50282.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for missing authorization issues while the upgrade waits. None of it replaces the fix.

The CVE-2026-50282 advisory

Craft CMS is a content management system (CMS). Versions 5.0.0-RC1 and above, prior to 5.9.21 and versions 4.0.0-RC1 and above prior to 4.17.14 contain an authorization issue where a forced folder move can delete a conflicting destination folder without destination delete permission. Function craft\\controllers\\AssetsController::actionMoveFolder() supports moving an asset folder into a destination parent folder. If a folder with the same name already exists at the destination, the action can be called with force=true to overwrite the destination. This issue has been resolved in versions 5.9.21 and 4.17.14.

Description from the CVE record, published by GitHub (the CVE Numbering Authority), via the NVD entry for CVE-2026-50282. Advisory title: “Craft CMS Vulnerable to Unauthorized Deletion of Destination Folders During Forced Moves”.

References

Other craftcms/cms advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit