craftcms/cms security advisory
CVE-2026-50280: Craft CMS: Authorization bypass in entries/move-to-section via missing target-section save check
CVE-2026-50280 is a medium-severity missing authorization vulnerability in the PHP package craftcms/cms (CVSS 6.0), published 2 July 2026. It is fixed in 5.9.21; earlier versions are affected. Exploiting it needs a low-privilege user account.
medium 6.0 published 2026-07-02 · updated 2026-10-25
- Affected versions
- >= 5.0.0-RC1, < 5.9.21
- Fixed in
- 5.9.21
- Newest release
- 5.12.0
- Severity
- Medium · CVSS 6.0
- Type
- Missing authorization check
CWE-284 - Exploited in the wild
- Not on the CISA KEV list
checked 2026-11-04
Is your craftcms/cms version affected?
Who can exploit CVE-2026-50280
- Access: A normal, low-privilege user account in the app.
- Conditions: It only works under specific conditions the attacker does not fully control (CVSS rates the attack as high complexity).
CVSS vector (scored by GitHub): CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N
How to fix CVE-2026-50280 in craftcms/cms
- Find the installed version:
composer show craftcms/cms. If you never required it yourself,composer why craftcms/cmsshows which package pulls it in. - Update it:
composer update craftcms/cms --with-all-dependencies. You need 5.9.21 or newer. - If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example
"craftcms/cms": "^5.9.21"if you can take that version), or upgrade the package that requires it. - Run
composer audit. It reads the same advisory data and should no longer list CVE-2026-50280. - Commit composer.lock and deploy it. On the server, run
composer install --no-devfrom the lock file, notcomposer update.
If you cannot upgrade yet
- Remove accounts you do not need and review what each role can do.
- Put the admin area behind a VPN, IP allow-list or extra login until you upgrade.
- If your app does not use the affected feature, note that in your audit, but still plan the upgrade.
The CVE-2026-50280 advisory
Craft CMS is a content management system (CMS). In versions 5.0.0-RC1 and above prior to 5.9.21, the EntriesController::actionMoveToSection() endpoint gates the destination section only by viewEntries:$section->uid rather than requiring saveEntries permission (the source entry is separately checked via Entry::canMove()). As a result, a low-privileged authenticated control-panel user who can move an entry out of its current section can call moveEntryToSection() to rewrite the entry's sectionId and save it into a section where they have read access but no write access. This breaks the section-level authorization model, letting a user with limited permissions inject content into a protected section and interfere with editorial boundaries, approval workflows, and section-specific business logic. This issue has been fixed in version 5.9.21.
References
- GitHub advisory GHSA-43cq-c2gq-pfpw github.com
- Fix commit 0a6b916 github.com
Other craftcms/cms advisories
- critical Craft CMS: Passkey login accepts replayed WebAuthn assertions 2026-08-07
- medium CVE-2026-72779: Craft CMS: Arbitrary file read via SplFileObject in non-sandboxed template contexts 2026-08-06
- medium CVE-2026-72782: Craft CMS: Authenticated leak of secret environment variables 2026-08-06
- medium CVE-2026-72785: Craft CMS: Authorization bypass: view-only Categories user can modify category structure via structures/move-element 2026-08-06
- medium CVE-2026-14794: Craft CMS: Missing authorization check allows non-admin control panel users access to user registration metrics 2026-08-06
- low CVE-2026-72783: Craft CMS: Incorrect path validation could potentially lead to path traversal 2026-08-06
Related
Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.
Ask about a fixWhere this data comes from
- Affected and fixed versions: the Packagist security advisories API (GitHub Advisory Database and FriendsOfPHP), the same data
composer audituses. Synced 2026-11-03. - Description, score, weakness and references: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Exploited-in-the-wild status: the CISA Known Exploited Vulnerabilities catalog, checked 2026-11-04.
- Compiled by Daniel Lasek at Laskyr from the sources above. The summary, “who can exploit it”, “how to fix it” and hardening sections are our plain-English reading of the record and are generated from it. The quoted description is the record's own text. Spot an error? Tell us.