Skip to content
Laskyr

october/system security advisory

CVE-2026-49400: October CMS: PHP Object Injection via Backend Widget Session Storage

CVE-2026-49400 is a low-severity PHP object injection vulnerability in the PHP package october/system (CVSS 3.3), published 14 September 2026. No fixed release exists yet: the newest version, 1.1.12, is affected. Exploiting it needs an admin-level account.

low 3.3 affects newest 1.1.12 published 2026-09-14 · updated 2026-09-30

No fixed release yet: october/system 1.1.12 is still affected

This PHP object injection issue affects october/system in 2 release lines: < 3.7.17; >= 4.0.0, < 4.2.23. The newest release, 1.1.12, is inside that range and no fixed version is named yet.

Affected versions
< 3.7.17
>= 4.0.0, < 4.2.23
Fixed in
no fix yet
Newest release
1.1.12
Severity
Low · CVSS 3.3
Type
PHP object injection
CWE-502
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

The sources disagree on the fixed version. The CVE text names 4.2.21, while Packagist's advisory data, which composer audit checks, names 4.2.23 for the same release line. Upgrade to the higher of the two (4.2.23) to be safe by both.

Is your october/system version affected?

Run composer show october/system in your project, then enter the version. We check it against this and every other known october/system advisory.

Who can exploit CVE-2026-49400

CVSS vector (scored by GitHub): CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:N

Your app is only exposed if it uses the affected part of october/system. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-49400 in october/system

  1. Find the installed version: composer show october/system. If you never required it yourself, composer why october/system shows which package pulls it in.
  2. There is no fixed release yet. Read the advisory below for a workaround, and avoid or switch off the affected feature until a fix ships.
  3. Check back on the october/system page. It updates daily from Packagist.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-49400.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

The advisory gives this workaround:

As a workaround, restrict CMS markup editing access to fully trusted administrators only, the standard October CMS recommendation for any deployment.

General hardening for PHP object injection issues while the upgrade waits. None of it replaces the fix.

The CVE-2026-49400 advisory

October System provides the system module for October Content Management System. Prior to versions 3.7.17 and 4.2.21, the backend `SessionMaker` trait stored widget session state as `base64(serialize(...))` and consumed it with `unserialize()` without an `allowed_classes` restriction. Any code path that could write to a `widget.*` session key with attacker-controlled bytes could trigger PHP object injection the next time the widget read its session state, allowing instantiation of arbitrary classes and reachable PHP gadget chains. This issue only affects installations running with `cms.safe_mode` enabled. Safe Mode is a niche opt-in feature, primarily used for demo installations and multi-tenant or shared-editor scenarios where untrusted users are deliberately granted access to the CMS markup editor. In standard production deployments Safe Mode is off, backend access is restricted to trusted administrators, and a markup editor can already execute arbitrary PHP directly. The session-write path that reaches this sink is gated by the Safe Mode sandbox, so installations without Safe Mode enabled are not exposed. Scope of impact is narrow even with Safe Mode enabled. The standard backend code paths that populate widget session state (search terms, sort options, selected IDs, filter values) wrap the input inside a known array shape before serializing, so user-supplied values never reach `unserialize()` as a controllable serialized payload. Exploitation requires the Safe Mode session-write path together with a suitable PHP gadget chain reachable from the installed dependency set. The hardening below removes the underlying object-injection sink so the class of issue is closed off regardless. The vulnerability has been patched in v3.7.17 and v4.2.21. Two changes were applied. `Backend\Traits\SessionMaker` now stores widget session state as plain JSON instead of `base64(serialize(...))`, eliminating the object-injection sink entirely for new writes. Reads transparently fall back to the legacy format for one upgrade cycle so existing sessions retain their saved widget state. The legacy `unserialize()` fallback path now sets `allowed_classes => false`, so even values written before the upgrade cannot instantiate objects. As a workaround, restrict CMS markup editing access to fully trusted administrators only, the standard October CMS recommendation for any deployment.

Description from the CVE record, published by GitHub (the CVE Numbering Authority), via the NVD entry for CVE-2026-49400. Advisory title: “October CMS: PHP Object Injection via Backend Widget Session Storage”.

References

Other october/system advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit