Skip to content
Laskyr

october/system security advisory

CVE-2026-29179: October CMS: Editor Sub-Permission Bypass for Asset and Blueprint File Operations

CVE-2026-29179 is a low-severity missing authorization vulnerability in the PHP package october/system (CVSS 3.3), published 21 April 2026. No fixed release exists yet: the newest version, 1.1.12, is affected. Exploiting it needs an admin-level account.

low 3.3 affects newest 1.1.12 published 2026-04-21 · updated 2026-10-26

No fixed release yet: october/system 1.1.12 is still affected

This missing authorization issue affects october/system in 2 release lines: < 3.7.16; >= 4.0.0, < 4.1.16. The newest release, 1.1.12, is inside that range and no fixed version is named yet.

Affected versions
< 3.7.16
>= 4.0.0, < 4.1.16
Fixed in
no fix yet
Newest release
1.1.12
Severity
Low · CVSS 3.3
Type
Missing authorization check
CWE-863
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your october/system version affected?

Run composer show october/system in your project, then enter the version. We check it against this and every other known october/system advisory.

Who can exploit CVE-2026-29179

CVSS vector (scored by GitHub): CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:N

Your app is only exposed if it uses the affected part of october/system. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-29179 in october/system

  1. Find the installed version: composer show october/system. If you never required it yourself, composer why october/system shows which package pulls it in.
  2. There is no fixed release yet. Read the advisory below for a workaround, and avoid or switch off the affected feature until a fix ships.
  3. Check back on the october/system page. It updates daily from Packagist.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-29179.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for missing authorization issues while the upgrade waits. None of it replaces the fix.

The CVE-2026-29179 advisory

October is a Content Management System (CMS) and web platform. Prior to 3.7.16 and 4.1.16, fine-grained sub-permission checks for asset and blueprint file operations were not enforced in the CMS and Tailor editor extensions. This only affects backend users who were explicitly granted editor access but had editor.cms_assets or editor.tailor_blueprints specifically withheld, an uncommon permission configuration. In this edge case, such users could perform file operations (create, delete, rename, move, upload) on theme assets or blueprint files despite lacking the required sub-permission. A related operator precedence error in the Tailor navigation also disclosed the theme blueprint directory tree under the same conditions. This vulnerability is fixed in 3.7.16 and 4.1.16.

Description from the CVE record, published by GitHub (the CVE Numbering Authority), via the NVD entry for CVE-2026-29179. Advisory title: “October CMS: Editor Sub-Permission Bypass for Asset and Blueprint File Operations”.

References

Other october/system advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit