october/system security advisory
CVE-2026-27937: October CMS: Reflected XSS via DataTable Form Widget
CVE-2026-27937 is a low-severity reflected XSS vulnerability in the PHP package october/system (CVSS 3.1), published 21 April 2026. No fixed release exists yet: the newest version, 1.1.12, is affected. It can be exploited without an account.
low 3.1 affects newest 1.1.12 published 2026-04-21 · updated 2026-10-26
- Affected versions
- < 3.7.16
>= 4.0.0, < 4.1.16 - Fixed in
- no fix yet
- Newest release
- 1.1.12
- Severity
- Low · CVSS 3.1
- Type
- Reflected cross-site scripting (XSS)
CWE-79 - Exploited in the wild
- Not on the CISA KEV list
checked 2026-11-04
Is your october/system version affected?
Who can exploit CVE-2026-27937
- Access: No account. Anyone who can send a request to an app that uses the affected code.
- Interaction: A user also has to do something, such as open a link or a page the attacker prepared.
- Conditions: It only works under specific conditions the attacker does not fully control (CVSS rates the attack as high complexity).
CVSS vector (scored by GitHub): CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:N
How to fix CVE-2026-27937 in october/system
- Find the installed version:
composer show october/system. If you never required it yourself,composer why october/systemshows which package pulls it in. - There is no fixed release yet. Read the advisory below for a workaround, and avoid or switch off the affected feature until a fix ships.
- Check back on the october/system page. It updates daily from Packagist.
- Run
composer audit. It reads the same advisory data and should no longer list CVE-2026-27937. - Commit composer.lock and deploy it. On the server, run
composer install --no-devfrom the lock file, notcomposer update.
If you cannot upgrade yet
- Escape output in your own templates and add a Content-Security-Policy that blocks inline scripts.
- Limit who can save the content the advisory names (for example rich text, SVG or form fields).
- If your app does not use the affected feature, note that in your audit, but still plan the upgrade.
The CVE-2026-27937 advisory
October is a Content Management System (CMS) and web platform. Prior to 3.7.16 and 4.1.16, a reflected Cross-Site Scripting (XSS) vulnerability was identified in the backend DataTable widget where a query parameter was rendered without proper output escaping. This vulnerability is fixed in 3.7.16 and 4.1.16.
References
- GitHub advisory GHSA-jj38-h5w5-mvpf github.com
Other october/system advisories
- low CVE-2026-49400: October CMS: PHP Object Injection via Backend Widget Session Storage 2026-09-14
- low CVE-2026-46696: October CMS: Safe Mode Sandbox Bypass via Session Store and Forwarded Builder Calls 2026-09-14
- low CVE-2026-29179: October CMS: Editor Sub-Permission Bypass for Asset and Blueprint File Operations 2026-04-21
- medium CVE-2026-26067: October CMS has Safe Mode Bypass via CSS Preprocessor Compilers 2026-04-21
- medium CVE-2026-24907: October CMS has Stored XSS in Event Log Mail Preview 2026-04-14
- medium CVE-2026-24906: October CMS has Stored XSS in Backend Editor Markup Classes 2026-04-14
Related
Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.
Ask about a fixWhere this data comes from
- Affected and fixed versions: the Packagist security advisories API (GitHub Advisory Database and FriendsOfPHP), the same data
composer audituses. Synced 2026-11-03. - Description, score, weakness and references: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Exploited-in-the-wild status: the CISA Known Exploited Vulnerabilities catalog, checked 2026-11-04.
- Compiled by Daniel Lasek at Laskyr from the sources above. The summary, “who can exploit it”, “how to fix it” and hardening sections are our plain-English reading of the record and are generated from it. The quoted description is the record's own text. Spot an error? Tell us.