Skip to content
Laskyr

october/system security advisory

CVE-2026-46696: October CMS: Safe Mode Sandbox Bypass via Session Store and Forwarded Builder Calls

CVE-2026-46696 is a low-severity privilege escalation vulnerability in the PHP package october/system (CVSS 3.3), published 14 September 2026. No fixed release exists yet: the newest version, 1.1.12, is affected. Exploiting it needs an admin-level account.

low 3.3 affects newest 1.1.12 published 2026-09-14 · updated 2026-09-30

No fixed release yet: october/system 1.1.12 is still affected

This privilege escalation issue affects october/system in 2 release lines: < 3.7.17; >= 4.0.0, < 4.2.23. The newest release, 1.1.12, is inside that range and no fixed version is named yet.

Affected versions
< 3.7.17
>= 4.0.0, < 4.2.23
Fixed in
no fix yet
Newest release
1.1.12
Severity
Low · CVSS 3.3
Type
Privilege escalation
CWE-269, CWE-284
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

The sources disagree on the fixed version. The CVE text names 4.2.21, while Packagist's advisory data, which composer audit checks, names 4.2.23 for the same release line. Upgrade to the higher of the two (4.2.23) to be safe by both.

Is your october/system version affected?

Run composer show october/system in your project, then enter the version. We check it against this and every other known october/system advisory.

Who can exploit CVE-2026-46696

CVSS vector (scored by GitHub): CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:N

Your app is only exposed if it uses the affected part of october/system. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-46696 in october/system

  1. Find the installed version: composer show october/system. If you never required it yourself, composer why october/system shows which package pulls it in.
  2. There is no fixed release yet. Read the advisory below for a workaround, and avoid or switch off the affected feature until a fix ships.
  3. Check back on the october/system page. It updates daily from Packagist.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-46696.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

The advisory gives this workaround:

A workaround is available.

General hardening for privilege escalation issues while the upgrade waits. None of it replaces the fix.

The CVE-2026-46696 advisory

October System provides the system module for October Content Management System. Versions prior to 3.7.17 and 4.2.21 have a vulnerability in the Twig sandbox security policy that allowed a chained bypass when `cms.safe_mode` is enabled. The Laravel session store was exposed to Twig with unrestricted method access, and raw SQL methods reachable through Eloquent's `__call` forwarding were not blocked across the full builder chain. When combined, a backend user with CMS markup editing access could read arbitrary database values via raw SQL expressions and write to the backend authentication session key, forging a backend session as another existing user. The scope of impact is narrow. Safe Mode is a niche feature, primarily used for demo installations and multi-tenant or shared-editor scenarios where untrusted users are deliberately granted access to the CMS markup editor. Standard production deployments do not enable Safe Mode, because under normal October CMS guidance backend access - including markup editing - is restricted to trusted administrators, and direct PHP injection through markup is already possible without Safe Mode in that configuration. This issue only affects sites that meet all of the following conditions: `cms.safe_mode` is enabled (a deliberate opt-in for demos or untrusted-editor scenarios; the site has at least one backend user with CMS markup editing access who is not intended to be trusted as a full administrator; and the site has at least one existing superuser account whose session the lower-privileged user can impersonate. The vulnerability has been patched in v3.7.17 and v4.2.21. The Laravel session store is now wrapped in a proxy that exposes only an explicit subset of read/write methods and rejects writes to reserved session key prefixes (`admin_auth`, `october_auth`, `login_*`, `_token`, and other framework internals). Raw SQL and subquery methods (`selectRaw`, `whereRaw`, `orderByRaw`, `joinSub`, and related) are now blocked on `Query\Builder`, `Eloquent\Builder`, and `Eloquent\Model` so the blocklist is consistent across the `__call` forwarding chain. All sites that enable `cms.safe_mode` are encouraged to upgrade to the latest patched version. A workaround is available. Restrict CMS markup editing access to fully trusted administrators only - the standard October CMS recommendation for any deployment. Note that disabling `cms.safe_mode` is not a workaround; Safe Mode is the boundary this issue affects, and disabling it removes the only sandbox between markup editors and the server.

Description from the CVE record, published by GitHub (the CVE Numbering Authority), via the NVD entry for CVE-2026-46696. Advisory title: “October CMS: Safe Mode Sandbox Bypass via Session Store and Forwarded Builder Calls”.

References

Other october/system advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit