Skip to content
Laskyr

october/system security advisory

CVE-2026-24906: October CMS has Stored XSS in Backend Editor Markup Classes

CVE-2026-24906 is a medium-severity stored XSS vulnerability in the PHP package october/system (CVSS 5.4), published 14 April 2026. No fixed release exists yet: the newest version, 1.1.12, is affected. Exploiting it needs a low-privilege user account.

medium 5.4 affects newest 1.1.12 published 2026-04-14 · updated 2026-10-26

No fixed release yet: october/system 1.1.12 is still affected

This stored XSS issue affects october/system in 2 release lines: <= 3.7.13; >= 4.0.0, <= 4.1.9. The newest release, 1.1.12, is inside that range and no fixed version is named yet.

Affected versions
<= 3.7.13
>= 4.0.0, <= 4.1.9
Fixed in
no fix yet
Newest release
1.1.12
Severity
Medium · CVSS 5.4
Type
Stored cross-site scripting (XSS)
CWE-79
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your october/system version affected?

Run composer show october/system in your project, then enter the version. We check it against this and every other known october/system advisory.

Who can exploit CVE-2026-24906

CVSS vector (scored by NVD): CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Your app is only exposed if it uses the affected part of october/system. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-24906 in october/system

  1. Find the installed version: composer show october/system. If you never required it yourself, composer why october/system shows which package pulls it in.
  2. There is no fixed release yet. Read the advisory below for a workaround, and avoid or switch off the affected feature until a fix ships.
  3. Check back on the october/system page. It updates daily from Packagist.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-24906.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

The advisory gives this workaround:

To workaround this issue, restrict editor settings permissions to fully trusted administrators only

General hardening for stored XSS issues while the upgrade waits. None of it replaces the fix.

The CVE-2026-24906 advisory

October is a Content Management System (CMS) and web platform. Versions prior to 3.7.14 and 4.1.10 contain a Stored Cross-Site Scripting (XSS) vulnerability in the Backend Editor Settings. The Markup Classes fields (used for paragraph styles, inline styles, table styles, etc.) did not sanitize input to valid CSS class name characters. Malicious values were rendered unsanitized in Froala editor dropdown menus, allowing JavaScript execution when any user opened a RichEditor. Exploitation could lead to privilege escalation if a superuser opens any RichEditor during routine content editing (e.g., editing a blog post), and requires authenticated backend access with editor settings permissions. This issue has been fixed in versions 3.7.14 and 4.1.10. To workaround this issue, restrict editor settings permissions to fully trusted administrators only

Description from the CVE record, published by GitHub (the CVE Numbering Authority), via the NVD entry for CVE-2026-24906. Advisory title: “October CMS has Stored XSS in Backend Editor Markup Classes”.

References

Other october/system advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit