Skip to content
Laskyr

craftcms/cms security advisory

CVE-2026-33162: Craft CMS has an authorization bypass which allows any control panel user to move entries without permissions

CVE-2026-33162 is a medium-severity missing authorization vulnerability in the PHP package craftcms/cms (CVSS 6.5), published 24 March 2026. The advisory does not name a fixed version. Exploiting it needs a low-privilege user account.

medium 6.5 published 2026-03-24 · updated 2026-06-17

The advisory does not name a fixed version

This missing authorization issue affects craftcms/cms versions >= 5.3.0, <= 5.9.13. The newest release (5.12.0) is outside the affected range.

Affected versions
>= 5.3.0, <= 5.9.13
Fixed in
not stated
Newest release
5.12.0
Severity
Medium · CVSS 6.5
Type
Missing authorization check
CWE-285, CWE-862
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your craftcms/cms version affected?

Run composer show craftcms/cms in your project, then enter the version. We check it against this and every other known craftcms/cms advisory.

Who can exploit CVE-2026-33162

CVSS vector (scored by NVD): CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N

Your app is only exposed if it uses the affected part of craftcms/cms. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-33162 in craftcms/cms

  1. Find the installed version: composer show craftcms/cms. If you never required it yourself, composer why craftcms/cms shows which package pulls it in.
  2. Update it: composer update craftcms/cms --with-all-dependencies.
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "craftcms/cms": "^5.12.0" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-33162.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for missing authorization issues while the upgrade waits. None of it replaces the fix.

The CVE-2026-33162 advisory

Craft CMS is a content management system (CMS). From version 5.3.0 to before version 5.9.14, an authenticated control panel user with only accessCp can move entries across sections via POST /actions/entries/move-to-section, even when they do not have saveEntries:{sectionUid} permission for either source or destination section. This issue has been patched in version 5.9.14.

Description from the CVE record, published by GitHub (the CVE Numbering Authority), via the NVD entry for CVE-2026-33162. Advisory title: “Craft CMS has an authorization bypass which allows any control panel user to move entries without permissions”.

References

Other craftcms/cms advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit