Skip to content
Laskyr

craftcms/cms security advisory

CVE-2026-33160: Craft CMS may expose private assets through anonymous "generate transform" calls via transform URL

CVE-2026-33160 is a low-severity missing authorization vulnerability in the PHP package craftcms/cms (CVSS 5.3), published 24 March 2026. The advisory does not name a fixed version. It can be exploited without an account.

low 5.3 published 2026-03-24 · updated 2026-06-17

The advisory does not name a fixed version

This missing authorization issue affects craftcms/cms in 2 release lines: >= 4.0.0-RC1, <= 4.17.7; >= 5.0.0-RC1, <= 5.9.13. The newest release (5.12.0) is outside the affected range.

Affected versions
>= 4.0.0-RC1, <= 4.17.7
>= 5.0.0-RC1, <= 5.9.13
Fixed in
not stated
Newest release
5.12.0
Severity
Low · CVSS 5.3
Type
Missing authorization check
CWE-639, CWE-862
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your craftcms/cms version affected?

Run composer show craftcms/cms in your project, then enter the version. We check it against this and every other known craftcms/cms advisory.

Who can exploit CVE-2026-33160

CVSS vector (scored by NVD): CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Your app is only exposed if it uses the affected part of craftcms/cms. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-33160 in craftcms/cms

  1. Find the installed version: composer show craftcms/cms. If you never required it yourself, composer why craftcms/cms shows which package pulls it in.
  2. Update it: composer update craftcms/cms --with-all-dependencies.
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "craftcms/cms": "^5.12.0" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-33160.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for missing authorization issues while the upgrade waits. None of it replaces the fix.

The CVE-2026-33160 advisory

Craft CMS is a content management system (CMS). From version 4.0.0-RC1 to before version 4.17.8 and from version 5.0.0-RC1 to before version 5.9.14, an unauthenticated user can call assets/generate-transform with a private assetId, receive a valid transform URL, and fetch transformed image bytes. The endpoint is anonymous and does not enforce per-asset authorization before returning the transform URL. This issue has been patched in versions 4.17.8 and 5.9.14.

Description from the CVE record, published by GitHub (the CVE Numbering Authority), via the NVD entry for CVE-2026-33160. Advisory title: “Craft CMS may expose private assets through anonymous "generate transform" calls via transform URL”.

References

Other craftcms/cms advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit