Skip to content
Laskyr

craftcms/cms security advisory

CVE-2026-32262: Craft CMS has a Path Traversal Vulnerability in AssetsController

CVE-2026-32262 is a medium-severity path traversal vulnerability in the PHP package craftcms/cms (CVSS 4.3), published 16 March 2026. The advisory does not name a fixed version. Exploiting it needs a low-privilege user account.

medium 4.3 published 2026-03-16 · updated 2026-06-17

The advisory does not name a fixed version

This path traversal issue affects craftcms/cms in 2 release lines: >= 4.0.0-RC1, <= 4.17.4; >= 5.0.0-RC1, <= 5.9.10. The newest release (5.12.0) is outside the affected range.

Affected versions
>= 4.0.0-RC1, <= 4.17.4
>= 5.0.0-RC1, <= 5.9.10
Fixed in
not stated
Newest release
5.12.0
Severity
Medium · CVSS 4.3
Type
Path traversal / file read
CWE-22
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your craftcms/cms version affected?

Run composer show craftcms/cms in your project, then enter the version. We check it against this and every other known craftcms/cms advisory.

Who can exploit CVE-2026-32262

CVSS vector (scored by NVD): CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N

Your app is only exposed if it uses the affected part of craftcms/cms. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-32262 in craftcms/cms

  1. Find the installed version: composer show craftcms/cms. If you never required it yourself, composer why craftcms/cms shows which package pulls it in.
  2. Update it: composer update craftcms/cms --with-all-dependencies.
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "craftcms/cms": "^5.12.0" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-32262.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for path traversal issues while the upgrade waits. None of it replaces the fix.

The CVE-2026-32262 advisory

Craft CMS is a content management system (CMS). From version 4.0.0-RC1 to before version 4.17.5 and from version 5.0.0-RC1 to before version 5.9.11, the AssetsController->replaceFile() method has a targetFilename body parameter that is used unsanitized in a deleteFile() call before Assets::prepareAssetName() is applied on save. This allows an authenticated user with replaceFiles permission to delete arbitrary files within the same filesystem root by injecting ../ path traversal sequences into the filename. This could allow an authenticated user with replaceFiles permission on one volume to delete files in other folders/volumes that share the same filesystem root. This only affects local filesystems. This issue has been patched in versions 4.17.5 and 5.9.11.

Description from the CVE record, published by GitHub (the CVE Numbering Authority), via the NVD entry for CVE-2026-32262. Advisory title: “Craft CMS has a Path Traversal Vulnerability in AssetsController”.

References

Other craftcms/cms advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit