Skip to content
Laskyr

craftcms/cms security advisory

CVE-2026-29113: Craft CMS has a potential information disclosure vulnerability in preview tokens

CVE-2026-29113 is a low-severity information disclosure vulnerability in the PHP package craftcms/cms (CVSS 4.3), published 10 March 2026. It is fixed in 4.17.3 and 5.9.7, one per release line; earlier versions on each line are affected. It can be exploited without an account.

low 4.3 published 2026-03-10 · updated 2026-09-02

Fixed in craftcms/cms 4.17.3 and 5.9.7

This information disclosure issue affects craftcms/cms in 2 release lines: >= 4.0.0-RC1, < 4.17.3; >= 5.0.0-RC1, < 5.9.7. Upgrade to the fixed version for your release line (4.17.3 and 5.9.7). The newest release, 5.12.0, is not affected.

Affected versions
>= 4.0.0-RC1, < 4.17.3
>= 5.0.0-RC1, < 5.9.7
Fixed in
4.17.3, 5.9.7
Newest release
5.12.0
Severity
Low · CVSS 4.3
Type
Information disclosure
CWE-352
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your craftcms/cms version affected?

Run composer show craftcms/cms in your project, then enter the version. We check it against this and every other known craftcms/cms advisory.

Who can exploit CVE-2026-29113

CVSS vector (scored by NVD): CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N

Your app is only exposed if it uses the affected part of craftcms/cms. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-29113 in craftcms/cms

  1. Find the installed version: composer show craftcms/cms. If you never required it yourself, composer why craftcms/cms shows which package pulls it in.
  2. Update it: composer update craftcms/cms --with-all-dependencies. You need the fixed version for your release line (4.17.3 and 5.9.7).
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "craftcms/cms": "^5.9.7" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-29113.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for information disclosure issues while the upgrade waits. None of it replaces the fix.

The CVE-2026-29113 advisory

Craft is a content management system (CMS). Prior to 4.17.3 and 5.9.7, Craft CMS has a CSRF issue in the preview token endpoint at /actions/preview/create-token. The endpoint accepts an attacker-supplied previewToken. Because the action does not require POST and does not enforce a CSRF token, an attacker can force a logged-in victim editor to mint a preview token chosen by the attacker. That token can then be used by the attacker (without authentication) to access previewed/unpublished content tied to the victim’s authorized preview scope. This vulnerability is fixed in 4.17.3 and 5.9.7.

Description from the CVE record, published by GitHub (the CVE Numbering Authority), via the NVD entry for CVE-2026-29113. Advisory title: “Craft CMS has a potential information disclosure vulnerability in preview tokens”.

References

Other craftcms/cms advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit