Skip to content
Laskyr

craftcms/cms security advisory

CVE-2026-28784: Craft CMS has potential authenticated Remote Code Execution via Twig SSTI

CVE-2026-28784 is a medium-severity remote code execution vulnerability in the PHP package craftcms/cms (CVSS 7.2), published 4 March 2026. It is fixed in 4.17.0-beta.1 and 5.9.0-beta.1, one per release line; earlier versions on each line are affected. Exploiting it needs an admin-level account.

medium 7.2 published 2026-03-04 · updated 2026-06-17

Fixed in craftcms/cms 4.17.0-beta.1 and 5.9.0-beta.1

This remote code execution issue affects craftcms/cms in 2 release lines: >= 4.0.0-RC1, < 4.17.0-beta.1; >= 5.0.0-RC1, < 5.9.0-beta.1. Upgrade to the fixed version for your release line (4.17.0-beta.1 and 5.9.0-beta.1). The newest release, 5.12.0, is not affected.

Affected versions
>= 4.0.0-RC1, < 4.17.0-beta.1
>= 5.0.0-RC1, < 5.9.0-beta.1
Fixed in
4.17.0-beta.1, 5.9.0-beta.1
Newest release
5.12.0
Severity
Medium · CVSS 7.2
Type
Remote code execution
CWE-1336
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your craftcms/cms version affected?

Run composer show craftcms/cms in your project, then enter the version. We check it against this and every other known craftcms/cms advisory.

Who can exploit CVE-2026-28784

CVSS vector (scored by NVD): CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Your app is only exposed if it uses the affected part of craftcms/cms. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-28784 in craftcms/cms

  1. Find the installed version: composer show craftcms/cms. If you never required it yourself, composer why craftcms/cms shows which package pulls it in.
  2. Update it: composer update craftcms/cms --with-all-dependencies. You need the fixed version for your release line (4.17.0-beta.1 and 5.9.0-beta.1).
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "craftcms/cms": "^5.9.0-beta.1" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-28784.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

The advisory gives this workaround:

Users should update to the patched versions (5.8.22 and 4.16.18) to mitigate the issue.

General hardening for remote code execution issues while the upgrade waits. None of it replaces the fix.

The CVE-2026-28784 advisory

Craft is a content management system (CMS). Prior to 5.8.22 and 4.16.18, it is possible to craft a malicious payload using the Twig map filter in text fields that accept Twig input under Settings in the Craft control panel or using the System Messages utility, which could lead to a RCE. For this to work, you must have administrator access to the Craft Control Panel, and allowAdminChanges must be enabled for this to work, which is against our recommendations for any non-dev environment. Alternatively, you can have a non-administrator account with allowAdminChanges disabled, but you have access to the System Messages utility. Users should update to the patched versions (5.8.22 and 4.16.18) to mitigate the issue.

Description from the CVE record, published by GitHub (the CVE Numbering Authority), via the NVD entry for CVE-2026-28784. Advisory title: “Craft CMS has potential authenticated Remote Code Execution via Twig SSTI”.

References

Other craftcms/cms advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit