Skip to content
Laskyr

craftcms/cms security advisory

CVE-2026-28782: Craft CMS has Permission Bypass and IDOR in Duplicate Entry Action

CVE-2026-28782 is a medium-severity missing authorization vulnerability in the PHP package craftcms/cms (CVSS 4.3), published 4 March 2026. It is fixed in 4.17.0-beta.1 and 5.9.0-beta.1, one per release line; earlier versions on each line are affected. Exploiting it needs a low-privilege user account.

medium 4.3 published 2026-03-04 · updated 2026-06-17

Fixed in craftcms/cms 4.17.0-beta.1 and 5.9.0-beta.1

This missing authorization issue affects craftcms/cms in 2 release lines: >= 4.0.0-RC1, < 4.17.0-beta.1; >= 5.0.0-RC1, < 5.9.0-beta.1. Upgrade to the fixed version for your release line (4.17.0-beta.1 and 5.9.0-beta.1). The newest release, 5.12.0, is not affected.

Affected versions
>= 4.0.0-RC1, < 4.17.0-beta.1
>= 5.0.0-RC1, < 5.9.0-beta.1
Fixed in
4.17.0-beta.1, 5.9.0-beta.1
Newest release
5.12.0
Severity
Medium · CVSS 4.3
Type
Missing authorization check
CWE-639
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your craftcms/cms version affected?

Run composer show craftcms/cms in your project, then enter the version. We check it against this and every other known craftcms/cms advisory.

Who can exploit CVE-2026-28782

CVSS vector (scored by NVD): CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N

Your app is only exposed if it uses the affected part of craftcms/cms. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-28782 in craftcms/cms

  1. Find the installed version: composer show craftcms/cms. If you never required it yourself, composer why craftcms/cms shows which package pulls it in.
  2. Update it: composer update craftcms/cms --with-all-dependencies. You need the fixed version for your release line (4.17.0-beta.1 and 5.9.0-beta.1).
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "craftcms/cms": "^5.9.0-beta.1" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-28782.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for missing authorization issues while the upgrade waits. None of it replaces the fix.

The CVE-2026-28782 advisory

Craft is a content management system (CMS). Prior to 5.9.0-beta.1 and 4.17.0-beta.1, the "Duplicate" entry action does not properly verify if the user has permission to perform this action on the specific target elements. Even with only "View Entries" permission (where the "Duplicate" action is restricted in the UI), a user can bypass this restriction by sending a direct request. Furthermore, this vulnerability allows duplicating other users' entries by specifying their Entry IDs. Since Entry IDs are incremental, an attacker can trivially brute-force these IDs to duplicate and access restricted content across the system. This vulnerability is fixed in 5.9.0-beta.1 and 4.17.0-beta.1.

Description from the CVE record, published by GitHub (the CVE Numbering Authority), via the NVD entry for CVE-2026-28782. Advisory title: “Craft CMS has Permission Bypass and IDOR in Duplicate Entry Action”.

References

Other craftcms/cms advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit