craftcms/cms security advisory
CVE-2026-25497: Craft CMS: GraphQL Asset Mutation Privilege Escalation
CVE-2026-25497 is a high-severity privilege escalation vulnerability in the PHP package craftcms/cms (CVSS 8.8), published 9 February 2026. It is fixed in 4.17.0-beta.1 and 5.9.0-beta.1, one per release line; earlier versions on each line are affected. Exploiting it needs a low-privilege user account.
high 8.8 published 2026-02-09 · updated 2026-06-17
- Affected versions
- >= 4.0.0-RC1, < 4.17.0-beta.1
>= 5.0.0-RC1, < 5.9.0-beta.1 - Fixed in
- 4.17.0-beta.1, 5.9.0-beta.1
- Newest release
- 5.12.0
- Severity
- High · CVSS 8.8
- Type
- Privilege escalation
CWE-639 - Exploited in the wild
- Not on the CISA KEV list
checked 2026-11-04
Is your craftcms/cms version affected?
Who can exploit CVE-2026-25497
- Access: A normal, low-privilege user account in the app.
CVSS vector (scored by NVD): CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
How to fix CVE-2026-25497 in craftcms/cms
- Find the installed version:
composer show craftcms/cms. If you never required it yourself,composer why craftcms/cmsshows which package pulls it in. - Update it:
composer update craftcms/cms --with-all-dependencies. You need the fixed version for your release line (4.17.0-beta.1 and 5.9.0-beta.1). - If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example
"craftcms/cms": "^5.9.0-beta.1"if you can take that version), or upgrade the package that requires it. - Run
composer audit. It reads the same advisory data and should no longer list CVE-2026-25497. - Commit composer.lock and deploy it. On the server, run
composer install --no-devfrom the lock file, notcomposer update.
If you cannot upgrade yet
- Remove accounts you do not need and review what each role can do.
- Put the admin area behind a VPN, IP allow-list or extra login until you upgrade.
- If your app does not use the affected feature, note that in your audit, but still plan the upgrade.
The CVE-2026-25497 advisory
Craft is a platform for creating digital experiences. In Craft versions from 4.0.0-RC1 to before 4.17.0-beta.1 and 5.9.0-beta.1, there is a Privilege Escalation vulnerability in Craft CMS’s GraphQL API that allows an authenticated user with write access to one asset volume to escalate their privileges and modify/transfer assets belonging to any other volume, including restricted or private volumes to which they should not have access. The saveAsset GraphQL mutation validates authorization against the schema-resolved volume but fetches the target asset by ID without verifying that the asset belongs to the authorized volume. This allows unauthorized cross-volume asset modification and transfer. This vulnerability is fixed in 4.17.0-beta.1 and 5.9.0-beta.1.
References
- GitHub advisory GHSA-fxp3-g6gw-4r4v github.com
- Fix commit ac7edf8 github.com
- Release 5.8.22 github.com
Other craftcms/cms advisories
- critical Craft CMS: Passkey login accepts replayed WebAuthn assertions 2026-08-07
- medium CVE-2026-72779: Craft CMS: Arbitrary file read via SplFileObject in non-sandboxed template contexts 2026-08-06
- medium CVE-2026-72782: Craft CMS: Authenticated leak of secret environment variables 2026-08-06
- medium CVE-2026-72785: Craft CMS: Authorization bypass: view-only Categories user can modify category structure via structures/move-element 2026-08-06
- medium CVE-2026-14794: Craft CMS: Missing authorization check allows non-admin control panel users access to user registration metrics 2026-08-06
- low CVE-2026-72783: Craft CMS: Incorrect path validation could potentially lead to path traversal 2026-08-06
Related
Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.
Ask about a fixWhere this data comes from
- Affected and fixed versions: the Packagist security advisories API (GitHub Advisory Database and FriendsOfPHP), the same data
composer audituses. Synced 2026-11-03. - Description, score, weakness and references: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Exploited-in-the-wild status: the CISA Known Exploited Vulnerabilities catalog, checked 2026-11-04.
- Compiled by Daniel Lasek at Laskyr from the sources above. The summary, “who can exploit it”, “how to fix it” and hardening sections are our plain-English reading of the record and are generated from it. The quoted description is the record's own text. Spot an error? Tell us.