Skip to content
Laskyr

craftcms/cms security advisory

CVE-2025-68454: Craft CMS vulnerable to potential authenticated Remote Code Execution via Twig SSTI

CVE-2025-68454 is a medium-severity remote code execution vulnerability in the PHP package craftcms/cms (CVSS 8.8), published 5 January 2026. The advisory does not name a fixed version. Exploiting it needs a low-privilege user account.

medium 8.8 published 2026-01-05 · updated 2026-10-07

The advisory does not name a fixed version

This remote code execution issue affects craftcms/cms in 2 release lines: >= 4.0.0-RC1, <= 4.16.16; >= 5.0.0-RC1, <= 5.8.20. The newest release (5.12.0) is outside the affected range.

Affected versions
>= 4.0.0-RC1, <= 4.16.16
>= 5.0.0-RC1, <= 5.8.20
Fixed in
not stated
Newest release
5.12.0
Severity
Medium · CVSS 8.8
Type
Remote code execution
CWE-1336
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your craftcms/cms version affected?

Run composer show craftcms/cms in your project, then enter the version. We check it against this and every other known craftcms/cms advisory.

Who can exploit CVE-2025-68454

CVSS vector (scored by NVD): CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Your app is only exposed if it uses the affected part of craftcms/cms. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2025-68454 in craftcms/cms

  1. Find the installed version: composer show craftcms/cms. If you never required it yourself, composer why craftcms/cms shows which package pulls it in.
  2. Update it: composer update craftcms/cms --with-all-dependencies.
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "craftcms/cms": "^5.12.0" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2025-68454.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

The advisory gives this workaround:

Users should update to the patched versions (5.8.21 and 4.16.17) to mitigate the issue.

General hardening for remote code execution issues while the upgrade waits. None of it replaces the fix.

The CVE-2025-68454 advisory

Craft is a platform for creating digital experiences. Versions 5.0.0-RC1 through 5.8.20 and 4.0.0-RC1 through 4.16.16 are vulnerable to potential authenticated Remote Code Execution via Twig SSTI. For this to work, users must have administrator access to the Craft Control Panel, and allowAdminChanges must be enabled, which is against Craft CMS' recommendations for any non-dev environment. Alternatively, a non-administrator account with allowAdminChanges disabled can be used, provided access to the System Messages utility is available. It is possible to craft a malicious payload using the Twig `map` filter in text fields that accept Twig input under Settings in the Craft control panel or using the System Messages utility, which could lead to a RCE. Users should update to the patched versions (5.8.21 and 4.16.17) to mitigate the issue.

Description from the CVE record, published by GitHub (the CVE Numbering Authority), via the NVD entry for CVE-2025-68454. Advisory title: “Craft CMS vulnerable to potential authenticated Remote Code Execution via Twig SSTI”.

References

Other craftcms/cms advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit