Skip to content
Laskyr

craftcms/cms security advisory

CVE-2025-68437: Craft CMS vulnerable to Server-Side Request Forgery (SSRF) via GraphQL Asset Upload Mutation

CVE-2025-68437 is a medium-severity SSRF vulnerability in the PHP package craftcms/cms (CVSS 6.8), published 5 January 2026. The advisory does not name a fixed version. Exploiting it needs an admin-level account.

medium 6.8 published 2026-01-05 · updated 2026-10-07

The advisory does not name a fixed version

This SSRF issue affects craftcms/cms in 2 release lines: >= 3.5.0, <= 4.16.16; >= 5.0.0-RC1, <= 5.8.20. The newest release (5.12.0) is outside the affected range.

Affected versions
>= 3.5.0, <= 4.16.16
>= 5.0.0-RC1, <= 5.8.20
Fixed in
not stated
Newest release
5.12.0
Severity
Medium · CVSS 6.8
Type
Server-side request forgery (SSRF)
CWE-918
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your craftcms/cms version affected?

Run composer show craftcms/cms in your project, then enter the version. We check it against this and every other known craftcms/cms advisory.

Who can exploit CVE-2025-68437

CVSS vector (scored by NVD): CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:N/A:N

Your app is only exposed if it uses the affected part of craftcms/cms. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2025-68437 in craftcms/cms

  1. Find the installed version: composer show craftcms/cms. If you never required it yourself, composer why craftcms/cms shows which package pulls it in.
  2. Update it: composer update craftcms/cms --with-all-dependencies.
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "craftcms/cms": "^5.12.0" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2025-68437.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

The advisory gives this workaround:

Users should update to the patched 5.8.21 and 4.16.17 releases to mitigate the issue.

General hardening for SSRF issues while the upgrade waits. None of it replaces the fix.

The CVE-2025-68437 advisory

Craft is a platform for creating digital experiences. In versions 5.0.0-RC1 through 5.8.20 and 4.0.0-RC1 through 4.16.16, the Craft CMS GraphQL `save_<VolumeName>_Asset` mutation is vulnerable to Server-Side Request Forgery (SSRF). This vulnerability arises because the `_file` input, specifically its `url` parameter, allows the server to fetch content from arbitrary remote locations without proper validation. Attackers can exploit this by providing internal IP addresses or cloud metadata endpoints as the `url`, forcing the server to make requests to these restricted services. The fetched content is then saved as an asset, which can subsequently be accessed and exfiltrated, leading to potential data exposure and infrastructure compromise. This exploitation requires specific GraphQL permissions for asset management within the targeted volume. Users should update to the patched 5.8.21 and 4.16.17 releases to mitigate the issue.

Description from the CVE record, published by GitHub (the CVE Numbering Authority), via the NVD entry for CVE-2025-68437. Advisory title: “Craft CMS vulnerable to Server-Side Request Forgery (SSRF) via GraphQL Asset Upload Mutation”.

References

Other craftcms/cms advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit