Skip to content
Laskyr

october/system security advisory

CVE-2025-61676: October CMS Vulnerable to Stored XSS via Branding Styles

CVE-2025-61676 is a medium-severity stored XSS vulnerability in the PHP package october/system (CVSS 4.8), published 10 January 2026. No fixed release exists yet: the newest version, 1.1.12, is affected. Exploiting it needs an admin-level account.

medium 4.8 affects newest 1.1.12 published 2026-01-10 · updated 2026-06-17

No fixed release yet: october/system 1.1.12 is still affected

This stored XSS issue affects october/system in 2 release lines: <= 3.7.12; >= 4.0.0, <= 4.0.11. The newest release, 1.1.12, is inside that range and no fixed version is named yet.

Affected versions
<= 3.7.12
>= 4.0.0, <= 4.0.11
Fixed in
no fix yet
Newest release
1.1.12
Severity
Medium · CVSS 4.8
Type
Stored cross-site scripting (XSS)
CWE-79
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your october/system version affected?

Run composer show october/system in your project, then enter the version. We check it against this and every other known october/system advisory.

Who can exploit CVE-2025-61676

CVSS vector (scored by NVD): CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N

Your app is only exposed if it uses the affected part of october/system. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2025-61676 in october/system

  1. Find the installed version: composer show october/system. If you never required it yourself, composer why october/system shows which package pulls it in.
  2. There is no fixed release yet. Read the advisory below for a workaround, and avoid or switch off the affected feature until a fix ships.
  3. Check back on the october/system page. It updates daily from Packagist.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2025-61676.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for stored XSS issues while the upgrade waits. None of it replaces the fix.

The CVE-2025-61676 advisory

October is a Content Management System (CMS) and web platform. Prior to versions 3.7.13 and 4.0.12, a cross-site scripting (XSS) vulnerabilities was identified in October CMS backend configuration forms. A user with the Customize Backend Styles permission could inject malicious HTML/JS into the stylesheet input at Styles from Branding & Appearance settings. A specially crafted input could break out of the intended <style> context, allowing arbitrary script execution across backend pages for all users. This issue has been patched in versions 3.7.13 and 4.0.12.

Description from the CVE record, published by GitHub (the CVE Numbering Authority), via the NVD entry for CVE-2025-61676. Advisory title: “October CMS Vulnerable to Stored XSS via Branding Styles”.

References

Other october/system advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit