pimcore/pimcore security advisory
CVE-2026-55416: Pimcore: SQL Injection in Custom Reports via Malicious Report Configuration
CVE-2026-55416 is a high-severity SQL injection vulnerability in the PHP package pimcore/pimcore (CVSS 8.8), published 14 September 2026. It is fixed in 11.5.18; earlier versions are affected. Exploiting it needs a low-privilege user account.
high 8.8 published 2026-09-14 · updated 2026-09-16
- Affected versions
- < 11.5.18
>= 12.0.0-RC1, <= 12.3.9
>= 2026.1.0, <= 2026.1.5 - Fixed in
- 11.5.18
- Newest release
- 2026.3.4
- Severity
- High · CVSS 8.8
- Type
- SQL injection
CWE-89 - Exploited in the wild
- Not on the CISA KEV list
checked 2026-11-04
Is your pimcore/pimcore version affected?
Who can exploit CVE-2026-55416
- Access: A normal, low-privilege user account in the app.
CVSS vector (scored by GitHub): CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
How to fix CVE-2026-55416 in pimcore/pimcore
- Find the installed version:
composer show pimcore/pimcore. If you never required it yourself,composer why pimcore/pimcoreshows which package pulls it in. - Update it:
composer update pimcore/pimcore --with-all-dependencies. You need 11.5.18 or newer. - If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example
"pimcore/pimcore": "^11.5.18"if you can take that version), or upgrade the package that requires it. - Run
composer audit. It reads the same advisory data and should no longer list CVE-2026-55416. - Commit composer.lock and deploy it. On the server, run
composer install --no-devfrom the lock file, notcomposer update.
If you cannot upgrade yet
- Make sure user input never reaches the affected query builder or ORM method unvalidated; allow-list column and sort names.
- Give the app's database user only the permissions it needs.
- If your app does not use the affected feature, note that in your audit, but still plan the upgrade.
The CVE-2026-55416 advisory
Pimcore is an Open Source Data & Experience Management Platform. Prior to 11.5.19, 12.3.10, and 2026.1.6, an authenticated user with reports_config permission can place attacker-controlled SQL fragments in the sql, from, where, and groupby fields of a Custom Reports configuration processed by bundles/CustomReportsBundle/src/Tool/Adapter/Sql.php. The buildQueryString() method concatenates these values into a database query, while a blacklist omits dangerous constructs such as additional data-manipulation statements, comments, subqueries, and multiple statements. The getData() method also previously interpolated offset and limit values into a LIMIT clause without integer casting. Executing the configured report reaches fetchAllAssociative() with the constructed query and can disclose, modify, or delete arbitrary database data. This issue is fixed in versions 11.5.19, 12.3.10, and 2026.1.6.
References
- GitHub advisory GHSA-23rh-xw42-fq82 github.com
- Fix commit 1999fee github.com
- Pull request #19175 github.com
- Release v12.3.10 github.com
- Release v2026.1.6 github.com
Other pimcore/pimcore advisories
- critical CVE-2026-55634: Pimcore Vulnerable to Remote Code Execution via DataObject Class-Definition Field Name 2026-08-28
- critical CVE-2026-55220: Pimcore Hotspotimage getDataFromResource() unrestricted Serialize::unserialize over object-store column (PHP Object Injection, CWE-502) 2026-08-28
- high CVE-2026-55072: Pimcore: ClassDefinition UID regex missing end anchor allows SQL injection via Block.php unquoted table name 2026-08-13
- high CVE-2026-11407: Pimcore CMS Twig Sandbox Bypass via SecurityPolicy checkMethodAllowed 2026-06-17
- high CVE-2026-5394: Pimcore Platform - SQL Injection in DataObject composite index handling during class definition import/save 2026-05-28
- high CVE-2026-45704: Pimcore has a CustomReports Share Bypass 2026-05-27
Related
Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.
Ask about a fixWhere this data comes from
- Affected and fixed versions: the Packagist security advisories API (GitHub Advisory Database and FriendsOfPHP), the same data
composer audituses. Synced 2026-11-03. - Description, score, weakness and references: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Exploited-in-the-wild status: the CISA Known Exploited Vulnerabilities catalog, checked 2026-11-04.
- Compiled by Daniel Lasek at Laskyr from the sources above. The summary, “who can exploit it”, “how to fix it” and hardening sections are our plain-English reading of the record and are generated from it. The quoted description is the record's own text. Spot an error? Tell us.