Skip to content
Laskyr

pimcore/pimcore security advisory

CVE-2026-5394: Pimcore Platform - SQL Injection in DataObject composite index handling during class definition import/save

CVE-2026-5394 is a high-severity SQL injection vulnerability in the PHP package pimcore/pimcore (CVSS 7.0), published 27 April 2026. It is fixed in 2026.1.3; earlier versions are affected. Exploiting it needs an admin-level account.

high 7.0 published 2026-04-27 · updated 2026-06-17

Fixed in pimcore/pimcore 2026.1.3

This SQL injection issue affects pimcore/pimcore in 3 release lines: <= 11.5.16; >= 12.0.0-RC1, <= 12.3.6; >= 2026.1.0, < 2026.1.3. Upgrade to the fixed version for your release line (2026.1.3). The newest release, 2026.3.4, is not affected.

Affected versions
<= 11.5.16
>= 12.0.0-RC1, <= 12.3.6
>= 2026.1.0, < 2026.1.3
Fixed in
2026.1.3
Newest release
2026.3.4
Severity
High · CVSS 7.0
Type
SQL injection
CWE-89
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your pimcore/pimcore version affected?

Run composer show pimcore/pimcore in your project, then enter the version. We check it against this and every other known pimcore/pimcore advisory.

Who can exploit CVE-2026-5394

CVSS vector (scored by Fluid Attacks): CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:L/VA:L/SC:N/SI:N/SA:N

Your app is only exposed if it uses the affected part of pimcore/pimcore. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-5394 in pimcore/pimcore

  1. Find the installed version: composer show pimcore/pimcore. If you never required it yourself, composer why pimcore/pimcore shows which package pulls it in.
  2. Update it: composer update pimcore/pimcore --with-all-dependencies. You need 2026.1.3 or newer.
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "pimcore/pimcore": "^2026.1.3" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-5394.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for SQL injection issues while the upgrade waits. None of it replaces the fix.

The CVE-2026-5394 advisory

An authenticated administrative user who can import or save DataObject class definitions can inject attacker-controlled composite index metadata and trigger unintended SQL execution in the backend. This issue affects pimcore: 12.3.3.

Description from the CVE record, published by Fluid Attacks (the CVE Numbering Authority), via the NVD entry for CVE-2026-5394. Advisory title: “Pimcore Platform - SQL Injection in DataObject composite index handling during class definition import/save”.

References

Other pimcore/pimcore advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit