pimcore/pimcore security advisory
CVE-2026-45704: Pimcore has a CustomReports Share Bypass
CVE-2026-45704 is a high-severity missing authorization vulnerability in the PHP package pimcore/pimcore (CVSS 7.1), published 17 July 2026. It is fixed in 2026.1.2; earlier versions are affected. Exploiting it needs a low-privilege user account.
high 7.1 published 2026-07-17 · updated 2026-07-22
- Affected versions
- <= 11.5.16
>= 12.0.0-RC1, <= 12.3.5
>= 2026.1.0, < 2026.1.2 - Fixed in
- 2026.1.2
- Newest release
- 2026.3.4
- Severity
- High · CVSS 7.1
- Type
- Missing authorization check
CWE-862 - Exploited in the wild
- Not on the CISA KEV list
checked 2026-11-04
Is your pimcore/pimcore version affected?
Who can exploit CVE-2026-45704
- Access: A normal, low-privilege user account in the app.
CVSS vector (scored by GitHub): CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N
How to fix CVE-2026-45704 in pimcore/pimcore
- Find the installed version:
composer show pimcore/pimcore. If you never required it yourself,composer why pimcore/pimcoreshows which package pulls it in. - Update it:
composer update pimcore/pimcore --with-all-dependencies. You need 2026.1.2 or newer. - If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example
"pimcore/pimcore": "^2026.1.2"if you can take that version), or upgrade the package that requires it. - Run
composer audit. It reads the same advisory data and should no longer list CVE-2026-45704. - Commit composer.lock and deploy it. On the server, run
composer install --no-devfrom the lock file, notcomposer update.
If you cannot upgrade yet
- Remove accounts you do not need and review what each role can do.
- Put the admin area behind a VPN, IP allow-list or extra login until you upgrade.
- If your app does not use the affected feature, note that in your audit, but still plan the upgrade.
The CVE-2026-45704 advisory
Pimcore is an Open Source Data & Experience Management Platform. Prior to 11.5.17 (LTS) and 12.3.6, CustomReports uses inconsistent authorization between the report listing endpoint and the report detail endpoint in bundles/CustomReportsBundle/src/Controller/Reports/CustomReportController.php and bundles/CustomReportsBundle/src/Tool/Config/Listing/Dao.php, allowing a low-privileged backend user with the reports permission to directly request an unshared report such as poc-secret-report by name and read report name, grouping information, display and icon metadata, data source configuration, column configuration, and sharing settings even when shareGlobally is false. This issue is fixed in versions 11.5.17 (LTS) and 12.3.6.
References
- GitHub advisory GHSA-jwcc-gv4m-93x6 github.com
- Fix commit 1893ff1 github.com
- Pull request #19099 github.com
- Release v12.3.6 github.com
Other pimcore/pimcore advisories
- high CVE-2026-55416: Pimcore: SQL Injection in Custom Reports via Malicious Report Configuration 2026-09-10
- critical CVE-2026-55634: Pimcore Vulnerable to Remote Code Execution via DataObject Class-Definition Field Name 2026-08-28
- critical CVE-2026-55220: Pimcore Hotspotimage getDataFromResource() unrestricted Serialize::unserialize over object-store column (PHP Object Injection, CWE-502) 2026-08-28
- high CVE-2026-55072: Pimcore: ClassDefinition UID regex missing end anchor allows SQL injection via Block.php unquoted table name 2026-08-13
- high CVE-2026-11407: Pimcore CMS Twig Sandbox Bypass via SecurityPolicy checkMethodAllowed 2026-06-17
- high CVE-2026-5394: Pimcore Platform - SQL Injection in DataObject composite index handling during class definition import/save 2026-05-28
Related
Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.
Ask about a fixWhere this data comes from
- Affected and fixed versions: the Packagist security advisories API (GitHub Advisory Database and FriendsOfPHP), the same data
composer audituses. Synced 2026-11-03. - Description, score, weakness and references: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Exploited-in-the-wild status: the CISA Known Exploited Vulnerabilities catalog, checked 2026-11-04.
- Compiled by Daniel Lasek at Laskyr from the sources above. The summary, “who can exploit it”, “how to fix it” and hardening sections are our plain-English reading of the record and are generated from it. The quoted description is the record's own text. Spot an error? Tell us.