Skip to content
Laskyr

pimcore/pimcore security advisory

CVE-2026-55072: Pimcore: ClassDefinition UID regex missing end anchor allows SQL injection via Block.php unquoted table name

CVE-2026-55072 is a high-severity SQL injection vulnerability in the PHP package pimcore/pimcore (CVSS 8.5), published 14 September 2026. It is fixed in 12.3.9; earlier versions are affected. Exploiting it needs a low-privilege user account.

high 8.5 published 2026-09-14 · updated 2026-09-16

Fixed in pimcore/pimcore 12.3.9

This SQL injection issue affects pimcore/pimcore in 2 release lines: < 12.3.9; >= 2026.1.0, <= 2026.1.4. Upgrade to the fixed version for your release line (12.3.9). The newest release, 2026.3.4, is not affected.

Affected versions
< 12.3.9
>= 2026.1.0, <= 2026.1.4
Fixed in
12.3.9
Newest release
2026.3.4
Severity
High · CVSS 8.5
Type
SQL injection
CWE-20, CWE-89
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your pimcore/pimcore version affected?

Run composer show pimcore/pimcore in your project, then enter the version. We check it against this and every other known pimcore/pimcore advisory.

Who can exploit CVE-2026-55072

CVSS vector (scored by GitHub): CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N

Your app is only exposed if it uses the affected part of pimcore/pimcore. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-55072 in pimcore/pimcore

  1. Find the installed version: composer show pimcore/pimcore. If you never required it yourself, composer why pimcore/pimcore shows which package pulls it in.
  2. Update it: composer update pimcore/pimcore --with-all-dependencies. You need 12.3.9 or newer.
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "pimcore/pimcore": "^12.3.9" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-55072.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for SQL injection issues while the upgrade waits. None of it replaces the fix.

The CVE-2026-55072 advisory

Pimcore is an Open Source Data & Experience Management Platform. Prior to 2026.1.5, an authenticated user with the objects permission can submit a malicious ClassDefinition UID because the name and ID validation expressions in models/DataObject/ClassDefinition.php validate only the beginning of each value. When a data object of that class containing a Block field is loaded, Block::load in models/DataObject/ClassDefinition/Data/Block.php incorporates the stored class ID into an unquoted object table identifier, allowing the UID to supply SQL syntax. The resulting query can read or modify arbitrary Pimcore database tables, including disclosure of password hashes, and the flaw represents an incomplete validation hardening because earlier work added a start anchor without enforcing the end of the identifier. This issue is fixed in version 2026.1.5.

Description from the CVE record, published by GitHub (the CVE Numbering Authority), via the NVD entry for CVE-2026-55072. Advisory title: “Pimcore: ClassDefinition UID regex missing end anchor allows SQL injection via Block.php unquoted table name”.

References

Other pimcore/pimcore advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit