symfony/security-http security advisory
CVE-2026-48489: Security Firewall Bypass via failure_forward Subrequest: Unauthenticated Access to access_control-Protected GET Routes in symfony/security-http
CVE-2026-48489 is a high-severity missing authorization vulnerability in the PHP package symfony/security-http (CVSS 7.5), published 14 July 2026. It is fixed in 5.4.53, 6.4.41, 7.4.13 and 8.0.13, one per release line; earlier versions on each line are affected. It can be exploited without an account.
high 7.5 published 2026-07-14 · updated 2026-07-16
- Affected versions
- >= 2.0.0, < 5.4.53
>= 6.0.0, < 6.4.41
>= 7.0.0, < 7.4.13
>= 8.0.0, < 8.0.13 - Fixed in
- 5.4.53, 6.4.41, 7.4.13, 8.0.13
- Newest release
- 8.1.10
- Severity
- High · CVSS 7.5
- Type
- Missing authorization check
CWE-863 - Exploited in the wild
- Not on the CISA KEV list
checked 2026-11-04
Also affects
- symfony/symfony >= 2.0.0, < 5.4.53; >= 6.0.0, < 6.4.41; >= 7.0.0, < 7.4.13; >= 8.0.0, < 8.0.13 fixed in 5.4.53, 6.4.41, 7.4.13, 8.0.13
Is your symfony/security-http version affected?
Who can exploit CVE-2026-48489
- Access: No account. Anyone who can send a request to an app that uses the affected code.
CVSS vector (scored by NVD): CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
How to fix CVE-2026-48489 in symfony/security-http
- Find the installed version:
composer show symfony/security-http. If you never required it yourself,composer why symfony/security-httpshows which package pulls it in. - Update it:
composer update symfony/security-http --with-all-dependencies. You need the fixed version for your release line (5.4.53, 6.4.41, 7.4.13 and 8.0.13). - If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example
"symfony/security-http": "^8.0.13"if you can take that version), or upgrade the package that requires it. - Run
composer audit. It reads the same advisory data and should no longer list CVE-2026-48489. - Commit composer.lock and deploy it. On the server, run
composer install --no-devfrom the lock file, notcomposer update.
If you cannot upgrade yet
- Remove accounts you do not need and review what each role can do.
- Put the admin area behind a VPN, IP allow-list or extra login until you upgrade.
- If your app does not use the affected feature, note that in your audit, but still plan the upgrade.
The CVE-2026-48489 advisory
Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 5.4.53, 6.4.41, 7.4.13, and 8.0.13, DefaultAuthenticationFailureHandler honored the request-supplied _failure_path parameter when failure_forward: true was enabled, allowing an unauthenticated failing login request to dispatch a subrequest to access_control-protected GET routes that skipped firewall listeners. This issue is fixed in versions 5.4.53, 6.4.41, 7.4.13, and 8.0.13.
References
- GitHub security advisory GHSA-6h46-9jf5-q59x github.com
- Symfony security advisory symfony.com
- Fix commit c48a427 github.com
- Release v5.4.53 github.com
- Release v6.4.41 github.com
- Release v7.4.13 github.com
Other symfony/security-http advisories
- high CVE-2026-45063: Identity Spoofing via Unanchored DN Regex in X509Authenticator 2026-05-20
- medium CVE-2026-45069: OidcTokenHandler Accepts JWTs Missing aud/iss/exp Claims 2026-05-20
- medium CVE-2026-45074: Cas2Handler Derives CAS service URL from Client Host Header → Cross-Service Ticket Replay 2026-05-20
- high CVE-2026-45075: HEAD Request Bypasses methods: ['GET'] Filter in #[IsGranted] / #[IsSignatureValid] / #[IsCsrfTokenValid] 2026-05-20
- high CVE-2024-51996: Authentication Bypass via persisted RememberMe cookie 2024-11-13
- medium CVE-2023-46733: Possible session fixation 2023-11-10
Related
Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.
Ask about a fixWhere this data comes from
- Affected and fixed versions: the Packagist security advisories API (GitHub Advisory Database and FriendsOfPHP), the same data
composer audituses. Synced 2026-11-03. - Description, score, weakness and references: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Exploited-in-the-wild status: the CISA Known Exploited Vulnerabilities catalog, checked 2026-11-04.
- Compiled by Daniel Lasek at Laskyr from the sources above. The summary, “who can exploit it”, “how to fix it” and hardening sections are our plain-English reading of the record and are generated from it. The quoted description is the record's own text. Spot an error? Tell us.