symfony/http-kernel security advisory
CVE-2026-45075: HEAD Request Bypasses methods: ['GET'] Filter in #[IsGranted] / #[IsSignatureValid] / #[IsCsrfTokenValid] in symfony/http-kernel
CVE-2026-45075 is a high-severity missing authorization vulnerability in the PHP package symfony/http-kernel (CVSS 8.2), published 14 July 2026. It is fixed in 7.4.12 and 8.0.12, one per release line; earlier versions on each line are affected. It can be exploited without an account.
high 8.2 published 2026-07-14 · updated 2026-07-16
- Affected versions
- >= 7.4.0, < 7.4.12
>= 8.0.0, < 8.0.12 - Fixed in
- 7.4.12, 8.0.12
- Newest release
- 8.1.10
- Severity
- High · CVSS 8.2
- Type
- Missing authorization check
CWE-863 - Exploited in the wild
- Not on the CISA KEV list
checked 2026-11-04
Also affects
- symfony/security-http >= 7.4.0, < 7.4.12; >= 8.0.0, < 8.0.12 fixed in 7.4.12, 8.0.12
- symfony/symfony >= 7.4.0, < 7.4.12; >= 8.0.0, < 8.0.12 fixed in 7.4.12, 8.0.12
Is your symfony/http-kernel version affected?
Who can exploit CVE-2026-45075
- Access: No account. Anyone who can send a request to an app that uses the affected code.
CVSS vector (scored by NVD): CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:N
How to fix CVE-2026-45075 in symfony/http-kernel
- Find the installed version:
composer show symfony/http-kernel. If you never required it yourself,composer why symfony/http-kernelshows which package pulls it in. - Update it:
composer update symfony/http-kernel --with-all-dependencies. You need the fixed version for your release line (7.4.12 and 8.0.12). - If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example
"symfony/http-kernel": "^8.0.12"if you can take that version), or upgrade the package that requires it. - Run
composer audit. It reads the same advisory data and should no longer list CVE-2026-45075. - Commit composer.lock and deploy it. On the server, run
composer install --no-devfrom the lock file, notcomposer update.
If you cannot upgrade yet
- Remove accounts you do not need and review what each role can do.
- Put the admin area behind a VPN, IP allow-list or extra login until you upgrade.
- If your app does not use the affected feature, note that in your audit, but still plan the upgrade.
The CVE-2026-45075 advisory
Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 7.4.12 and 8.0.12, method-scoped #[IsGranted], #[IsSignatureValid], and #[IsCsrfTokenValid] attributes can be configured for GET only, but Symfony routes HEAD requests to the GET handler while the attribute check is skipped, allowing protected controllers to execute and leak headers or perform side effects. This issue is fixed in versions 7.4.12 and 8.0.12.
References
- GitHub security advisory GHSA-6439-2f28-8p8q github.com
- Symfony security advisory symfony.com
- Release v7.4.12 github.com
- Release v8.0.12 github.com
Other symfony/http-kernel advisories
- medium CVE-2022-24894: Prevent storing cookie headers in HttpCache 2023-02-01
- medium CVE-2021-41267: Webcache Poisoning via X-Forwarded-Prefix and sub-request 2021-10-09
- high CVE-2020-15094: Prevent RCE when calling untrusted remote with CachingHttpClient 2020-09-02
- high CVE-2019-18887: Use constant time comparison in UriSigner 2019-11-13
- medium CVE-2015-4050: ESI unauthorized access 2015-05-26
- medium CVE-2015-2308: Esi Code Injection 2015-04-01
Related
Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.
Ask about a fixWhere this data comes from
- Affected and fixed versions: the Packagist security advisories API (GitHub Advisory Database and FriendsOfPHP), the same data
composer audituses. Synced 2026-11-03. - Description, score, weakness and references: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Exploited-in-the-wild status: the CISA Known Exploited Vulnerabilities catalog, checked 2026-11-04.
- Compiled by Daniel Lasek at Laskyr from the sources above. The summary, “who can exploit it”, “how to fix it” and hardening sections are our plain-English reading of the record and are generated from it. The quoted description is the record's own text. Spot an error? Tell us.