Skip to content
Laskyr

symfony/security-http security advisory

CVE-2026-45063: Identity Spoofing via Unanchored DN Regex in X509Authenticator in symfony/security-http

CVE-2026-45063 is a high-severity security vulnerability in the PHP package symfony/security-http (CVSS 9.1), published 14 July 2026. It is fixed in 5.4.52, 6.4.40, 7.4.12 and 8.0.12, one per release line; earlier versions on each line are affected. It can be exploited without an account.

high 9.1 published 2026-07-14 · updated 2026-07-15

Fixed in symfony/security-http 5.4.52, 6.4.40, 7.4.12 and 8.0.12

This security issue affects symfony/security-http in 4 release lines: >= 2.0.0, < 5.4.52; >= 6.0.0, < 6.4.40; >= 7.0.0, < 7.4.12; >= 8.0.0, < 8.0.12. Upgrade to the fixed version for your release line (5.4.52, 6.4.40, 7.4.12 and 8.0.12). The newest release, 8.1.10, is not affected.

Affected versions
>= 2.0.0, < 5.4.52
>= 6.0.0, < 6.4.40
>= 7.0.0, < 7.4.12
>= 8.0.0, < 8.0.12
Fixed in
5.4.52, 6.4.40, 7.4.12, 8.0.12
Newest release
8.1.10
Severity
High · CVSS 9.1
Type
Security issue
CWE-290
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Also affects

The same advisory covers another package in our list. Fix whichever one your project installs.

Is your symfony/security-http version affected?

Run composer show symfony/security-http in your project, then enter the version. We check it against this and every other known symfony/security-http advisory.

Who can exploit CVE-2026-45063

CVSS vector (scored by NVD): CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Your app is only exposed if it uses the affected part of symfony/security-http. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-45063 in symfony/security-http

  1. Find the installed version: composer show symfony/security-http. If you never required it yourself, composer why symfony/security-http shows which package pulls it in.
  2. Update it: composer update symfony/security-http --with-all-dependencies. You need the fixed version for your release line (5.4.52, 6.4.40, 7.4.12 and 8.0.12).
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "symfony/security-http": "^8.0.12" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-45063.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for this kind of issue while the upgrade waits. None of it replaces the fix.

The CVE-2026-45063 advisory

Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 5.4.52, 6.4.40, 7.4.12, and 8.0.12, X509Authenticator extracts the user identifier from $_SERVER['SSL_CLIENT_S_DN'] with an unanchored regex that matches emailAddress= anywhere in the distinguished name, allowing an attacker with a trusted certificate containing emailAddress=victim inside another RDN value such as CN to authenticate as the victim. This issue is fixed in versions 5.4.52, 6.4.40, 7.4.12, and 8.0.12.

Description from the CVE record, published by GitHub (the CVE Numbering Authority), via the NVD entry for CVE-2026-45063. Advisory title: “CVE-2026-45063: Identity Spoofing via Unanchored DN Regex in X509Authenticator”.

References

Other symfony/security-http advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit