symfony/security-http security advisory
CVE-2026-45074: Cas2Handler Derives CAS service URL from Client Host Header → Cross-Service Ticket Replay in symfony/security-http
CVE-2026-45074 is a medium-severity security vulnerability in the PHP package symfony/security-http (CVSS 8.1), published 14 July 2026. It is fixed in 7.4.12 and 8.0.12, one per release line; earlier versions on each line are affected. It can be exploited without an account.
medium 8.1 published 2026-07-14 · updated 2026-07-15
- Affected versions
- >= 7.1.0, < 7.4.12
>= 8.0.0, < 8.0.12 - Fixed in
- 7.4.12, 8.0.12
- Newest release
- 8.1.10
- Severity
- Medium · CVSS 8.1
- Type
- Security issue
CWE-290 - Exploited in the wild
- Not on the CISA KEV list
checked 2026-11-04
Also affects
- symfony/symfony >= 7.1.0, < 7.4.12; >= 8.0.0, < 8.0.12 fixed in 7.4.12, 8.0.12
Is your symfony/security-http version affected?
Who can exploit CVE-2026-45074
- Access: No account. Anyone who can send a request to an app that uses the affected code.
- Interaction: A user also has to do something, such as open a link or a page the attacker prepared.
CVSS vector (scored by NVD): CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
How to fix CVE-2026-45074 in symfony/security-http
- Find the installed version:
composer show symfony/security-http. If you never required it yourself,composer why symfony/security-httpshows which package pulls it in. - Update it:
composer update symfony/security-http --with-all-dependencies. You need the fixed version for your release line (7.4.12 and 8.0.12). - If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example
"symfony/security-http": "^8.0.12"if you can take that version), or upgrade the package that requires it. - Run
composer audit. It reads the same advisory data and should no longer list CVE-2026-45074. - Commit composer.lock and deploy it. On the server, run
composer install --no-devfrom the lock file, notcomposer update.
If you cannot upgrade yet
- If your app does not use the affected feature, note that in your audit, but still plan the upgrade.
The CVE-2026-45074 advisory
Symfony is a PHP framework for web and console applications and a set of reusable PHP components. From 7.1.0 until 7.4.12 and 8.0.12, Cas2Handler builds the CAS service parameter from Request::getSchemeAndHttpHost(), which reflects an attacker-controlled Host header when framework.trusted_hosts is not configured; an attacker controlling another application registered with the same CAS server can replay a victim ticket against the Symfony application and authenticate as the victim. This issue is fixed in versions 7.4.12 and 8.0.12.
References
- GitHub security advisory GHSA-j8gj-9rm5-4xhx github.com
- Symfony security advisory symfony.com
- Fix commit 5ba145d github.com
- Release v7.4.12 github.com
- Release v8.0.12 github.com
Other symfony/security-http advisories
- high CVE-2026-48489: Security Firewall Bypass via failure_forward Subrequest: Unauthenticated Access to access_control-Protected GET Routes 2026-05-26
- high CVE-2026-45063: Identity Spoofing via Unanchored DN Regex in X509Authenticator 2026-05-20
- medium CVE-2026-45069: OidcTokenHandler Accepts JWTs Missing aud/iss/exp Claims 2026-05-20
- high CVE-2026-45075: HEAD Request Bypasses methods: ['GET'] Filter in #[IsGranted] / #[IsSignatureValid] / #[IsCsrfTokenValid] 2026-05-20
- high CVE-2024-51996: Authentication Bypass via persisted RememberMe cookie 2024-11-13
- medium CVE-2023-46733: Possible session fixation 2023-11-10
Related
Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.
Ask about a fixWhere this data comes from
- Affected and fixed versions: the Packagist security advisories API (GitHub Advisory Database and FriendsOfPHP), the same data
composer audituses. Synced 2026-11-03. - Description, score, weakness and references: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Exploited-in-the-wild status: the CISA Known Exploited Vulnerabilities catalog, checked 2026-11-04.
- Compiled by Daniel Lasek at Laskyr from the sources above. The summary, “who can exploit it”, “how to fix it” and hardening sections are our plain-English reading of the record and are generated from it. The quoted description is the record's own text. Spot an error? Tell us.