Skip to content
Laskyr

typo3/cms-core security advisory

CVE-2026-47348: TYPO3-CORE-SA-2026-010: Cross-Site Scripting in Indexed Search

CVE-2026-47348 is a medium-severity XSS vulnerability in the PHP package typo3/cms-core (CVSS 5.1), published 9 June 2026. It is fixed in 13.4.31 and 14.3.3, one per release line; earlier versions on each line are affected. Exploiting it needs a low-privilege user account.

medium 5.1 published 2026-06-09 · updated 2026-07-23

Fixed in typo3/cms-core 13.4.31 and 14.3.3

This XSS issue affects typo3/cms-core in 2 release lines: >= 13.0.0, < 13.4.31; >= 14.0.0, < 14.3.3. Upgrade to the fixed version for your release line (13.4.31 and 14.3.3). The newest release, 14.3.10, is not affected.

Affected versions
>= 13.0.0, < 13.4.31
>= 14.0.0, < 14.3.3
Fixed in
13.4.31, 14.3.3
Newest release
14.3.10
Severity
Medium · CVSS 5.1
Type
Cross-site scripting (XSS)
CWE-79
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your typo3/cms-core version affected?

Run composer show typo3/cms-core in your project, then enter the version. We check it against this and every other known typo3/cms-core advisory.

Who can exploit CVE-2026-47348

CVSS vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:N/SC:N/SI:L/SA:N

Your app is only exposed if it uses the affected part of typo3/cms-core. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-47348 in typo3/cms-core

  1. Find the installed version: composer show typo3/cms-core. If you never required it yourself, composer why typo3/cms-core shows which package pulls it in.
  2. Update it: composer update typo3/cms-core --with-all-dependencies. You need the fixed version for your release line (13.4.31 and 14.3.3).
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "typo3/cms-core": "^14.3.3" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-47348.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for XSS issues while the upgrade waits. None of it replaces the fix.

The CVE-2026-47348 advisory

Editors with access to create or modify page content were able to include HTML markup in page titles that were stored in the search index without sanitization. When displayed in frontend search results via the Indexed Search plugin, these titles were rendered without proper output encoding, resulting in a Cross-Site Scripting vulnerability. This issue affects TYPO3 CMS versions 13.0.0-13.4.30 and 14.0.0-14.3.2.

Description from the CVE record, via the NVD entry for CVE-2026-47348. Advisory title: “TYPO3-CORE-SA-2026-010: Cross-Site Scripting in Indexed Search”.

References

Other typo3/cms-core advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit