Skip to content
Laskyr

typo3/cms-core security advisory

CVE-2026-49738: TYPO3-CORE-SA-2026-016: Broken Access Control in File Abstraction Layer

CVE-2026-49738 is a low-severity missing authorization vulnerability in the PHP package typo3/cms-core (CVSS 2.1), published 9 June 2026. It is fixed in 10.4.57, 11.5.51, 12.4.46, 13.4.31 and 14.3.3, one per release line; earlier versions on each line are affected. Exploiting it needs an admin-level account.

low 2.1 published 2026-06-09 · updated 2026-07-23

Fixed in typo3/cms-core 10.4.57, 11.5.51, 12.4.46, 13.4.31 and 14.3.3

This missing authorization issue affects typo3/cms-core in 5 release lines: < 10.4.57; >= 11.0.0, < 11.5.51; >= 12.0.0, < 12.4.46; >= 13.0.0, < 13.4.31; >= 14.0.0, < 14.3.3. Upgrade to the fixed version for your release line (10.4.57, 11.5.51, 12.4.46, 13.4.31 and 14.3.3). The newest release, 14.3.10, is not affected.

Affected versions
< 10.4.57
>= 11.0.0, < 11.5.51
>= 12.0.0, < 12.4.46
>= 13.0.0, < 13.4.31
>= 14.0.0, < 14.3.3
Fixed in
10.4.57, 11.5.51, 12.4.46, 13.4.31, 14.3.3
Newest release
14.3.10
Severity
Low · CVSS 2.1
Type
Missing authorization check
CWE-22
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your typo3/cms-core version affected?

Run composer show typo3/cms-core in your project, then enter the version. We check it against this and every other known typo3/cms-core advisory.

Who can exploit CVE-2026-49738

CVSS vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N

Your app is only exposed if it uses the affected part of typo3/cms-core. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-49738 in typo3/cms-core

  1. Find the installed version: composer show typo3/cms-core. If you never required it yourself, composer why typo3/cms-core shows which package pulls it in.
  2. Update it: composer update typo3/cms-core --with-all-dependencies. You need the fixed version for your release line (10.4.57, 11.5.51, 12.4.46, 13.4.31 and 14.3.3).
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "typo3/cms-core": "^14.3.3" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-49738.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for missing authorization issues while the upgrade waits. None of it replaces the fix.

The CVE-2026-49738 advisory

The path allowance check in GeneralUtility::isAllowedAbsPath() performed a plain string prefix comparison without requiring a directory separator boundary, causing a path like /var/www/html-other/secret.yaml to be incorrectly accepted as valid when the project root was /var/www/html. Administrator users with access to the File Abstraction Layer were able to create new file storage definitions pointing to directories outside the project root, bypassing this path check. This issue affects TYPO3 CMS versions before 10.4.57, 11.0.0-11.5.50, 12.0.0-12.4.45, 13.0.0-13.4.30 and 14.0.0-14.3.2.

Description from the CVE record, via the NVD entry for CVE-2026-49738. Advisory title: “TYPO3-CORE-SA-2026-016: Broken Access Control in File Abstraction Layer”.

References

Other typo3/cms-core advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit