typo3/cms-core security advisory
CVE-2026-19418: TYPO3-CORE-SA-2026-021: Broken Access Control in Backend and Install Tool
CVE-2026-19418 is a high-severity missing authorization vulnerability in the PHP package typo3/cms-core (CVSS 7.3), published 11 August 2026. It is fixed in 13.4.34 and 14.3.6, one per release line; earlier versions on each line are affected. Exploiting it needs a low-privilege user account.
high 7.3 published 2026-08-11 · updated 2026-10-23
- Affected versions
- >= 13.0.0, < 13.4.34
>= 14.0.0, < 14.3.6 - Fixed in
- 13.4.34, 14.3.6
- Newest release
- 14.3.10
- Severity
- High · CVSS 7.3
- Type
- Missing authorization check
CWE-346, CWE-352 - Exploited in the wild
- Not on the CISA KEV list
checked 2026-11-04
Is your typo3/cms-core version affected?
Who can exploit CVE-2026-19418
- Access: A normal, low-privilege user account in the app.
- Interaction: A user also has to do something, such as open a link or a page the attacker prepared.
- Conditions: It only works under specific conditions the attacker does not fully control (CVSS rates the attack as high complexity).
CVSS vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
How to fix CVE-2026-19418 in typo3/cms-core
- Find the installed version:
composer show typo3/cms-core. If you never required it yourself,composer why typo3/cms-coreshows which package pulls it in. - Update it:
composer update typo3/cms-core --with-all-dependencies. You need the fixed version for your release line (13.4.34 and 14.3.6). - If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example
"typo3/cms-core": "^14.3.6"if you can take that version), or upgrade the package that requires it. - Run
composer audit. It reads the same advisory data and should no longer list CVE-2026-19418. - Commit composer.lock and deploy it. On the server, run
composer install --no-devfrom the lock file, notcomposer update.
If you cannot upgrade yet
- Remove accounts you do not need and review what each role can do.
- Put the admin area behind a VPN, IP allow-list or extra login until you upgrade.
- If your app does not use the affected feature, note that in your audit, but still plan the upgrade.
The CVE-2026-19418 advisory
The referrer enforcement introduced with TYPO3-CORE-SA-2020-006 (CVE-2020-11069) became ineffective in TYPO3 v13.0, where TYPO3 CMS started serving the backend and Install Tool applications from the site's main entry script instead of the dedicated typo3/ directory. Whether a request originated from the backend or Install Tool itself was determined by comparing the referrer against the directory of the entry script, which since then is the site root. As a consequence, requests originating from any script running on one of the TYPO3 instance's own domains, such as a frontend page, were accepted by backend routes and Install Tool endpoints. Attackers able to execute JavaScript on one of those domains, for instance by exploiting a cross-site scripting vulnerability, could invoke these endpoints via Fetch/XHR with the privileges of an authenticated victim's user session. This issue affects TYPO3 CMS versions 13.0.0-13.4.33 and 14.0.0-14.3.5.
References
- News security advisory news.typo3.com
- Typo3 security advisory typo3.org
- Typo3 security advisory typo3.org
- Fix commit 4a75e86 github.com
- Fix commit a0e8ee0 github.com
- Fix commit ae0abd3 github.com
Other typo3/cms-core advisories
- high CVE-2026-11607: TYPO3-CORE-SA-2026-019: Broken Access Control in Form Framework 2026-06-09
- medium CVE-2026-49740: TYPO3-CORE-SA-2026-018: Insecure Deserialization in Core API 2026-06-09
- high CVE-2026-49741: TYPO3-CORE-SA-2026-017: Privilege Escalation & SQL Injection in Form Framework 2026-06-09
- low CVE-2026-49738: TYPO3-CORE-SA-2026-016: Broken Access Control in File Abstraction Layer 2026-06-09
- medium CVE-2026-47352: TYPO3-CORE-SA-2026-015: Broken Access Control in Backend API 2026-06-09
- medium CVE-2026-47351: TYPO3-CORE-SA-2026-014: Broken Access Control in Clipboard 2026-06-09
Related
Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.
Ask about a fixWhere this data comes from
- Affected and fixed versions: the Packagist security advisories API (GitHub Advisory Database and FriendsOfPHP), the same data
composer audituses. Synced 2026-11-03. - Description, score, weakness and references: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Exploited-in-the-wild status: the CISA Known Exploited Vulnerabilities catalog, checked 2026-11-04.
- Compiled by Daniel Lasek at Laskyr from the sources above. The summary, “who can exploit it”, “how to fix it” and hardening sections are our plain-English reading of the record and are generated from it. The quoted description is the record's own text. Spot an error? Tell us.