Skip to content
Laskyr

typo3/cms-core security advisory

CVE-2026-49741: TYPO3-CORE-SA-2026-017: Privilege Escalation & SQL Injection in Form Framework

CVE-2026-49741 is a high-severity SQL injection vulnerability in the PHP package typo3/cms-core (CVSS 8.7), published 9 June 2026. It is fixed in 14.3.3; earlier versions are affected. Exploiting it needs a low-privilege user account.

high 8.7 published 2026-06-09 · updated 2026-07-23

Fixed in typo3/cms-core 14.3.3

This SQL injection issue affects typo3/cms-core versions >= 14.0.0, < 14.3.3. Upgrade to the fixed version for your release line (14.3.3). The newest release, 14.3.10, is not affected.

Affected versions
>= 14.0.0, < 14.3.3
Fixed in
14.3.3
Newest release
14.3.10
Severity
High · CVSS 8.7
Type
SQL injection
CWE-89, CWE-862
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your typo3/cms-core version affected?

Run composer show typo3/cms-core in your project, then enter the version. We check it against this and every other known typo3/cms-core advisory.

Who can exploit CVE-2026-49741

CVSS vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N

Your app is only exposed if it uses the affected part of typo3/cms-core. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-49741 in typo3/cms-core

  1. Find the installed version: composer show typo3/cms-core. If you never required it yourself, composer why typo3/cms-core shows which package pulls it in.
  2. Update it: composer update typo3/cms-core --with-all-dependencies. You need 14.3.3 or newer.
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "typo3/cms-core": "^14.3.3" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-49741.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for SQL injection issues while the upgrade waits. None of it replaces the fix.

The CVE-2026-49741 advisory

Backend users with write access to the form_definition database table were able to directly create, update, or delete form definition records via DataHandler, bypassing the Form Framework's persistence validation and permission checks. This allowed injecting arbitrary form configurations, re-enabling attack vectors originally addressed in TYPO3-CORE-SA-2018-003, including SQL injection and privilege escalation. This issue affects TYPO3 CMS versions 14.0.0-14.3.2.

Description from the CVE record, via the NVD entry for CVE-2026-49741. Advisory title: “TYPO3-CORE-SA-2026-017: Privilege Escalation &amp; SQL Injection in Form Framework”.

References

Other typo3/cms-core advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit