typo3/cms-core security advisory
CVE-2026-47346: TYPO3-CORE-SA-2026-008: Broken Access Control in Form Framework
CVE-2026-47346 is a high-severity missing authorization vulnerability in the PHP package typo3/cms-core (CVSS 7.6), published 9 June 2026. It is fixed in 10.4.57, 11.5.51, 12.4.46, 13.4.31 and 14.3.3, one per release line; earlier versions on each line are affected. Exploiting it needs a low-privilege user account.
high 7.6 published 2026-06-09 · updated 2026-07-23
- Affected versions
- < 10.4.57
>= 11.0.0, < 11.5.51
>= 12.0.0, < 12.4.46
>= 13.0.0, < 13.4.31
>= 14.0.0, < 14.3.3 - Fixed in
- 10.4.57, 11.5.51, 12.4.46, 13.4.31, 14.3.3
- Newest release
- 14.3.10
- Severity
- High · CVSS 7.6
- Type
- Missing authorization check
CWE-178, CWE-862 - Exploited in the wild
- Not on the CISA KEV list
checked 2026-11-04
Is your typo3/cms-core version affected?
Who can exploit CVE-2026-47346
- Access: A normal, low-privilege user account in the app.
- Conditions: It only works under specific conditions the attacker does not fully control (CVSS rates the attack as high complexity).
CVSS vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
How to fix CVE-2026-47346 in typo3/cms-core
- Find the installed version:
composer show typo3/cms-core. If you never required it yourself,composer why typo3/cms-coreshows which package pulls it in. - Update it:
composer update typo3/cms-core --with-all-dependencies. You need the fixed version for your release line (10.4.57, 11.5.51, 12.4.46, 13.4.31 and 14.3.3). - If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example
"typo3/cms-core": "^14.3.3"if you can take that version), or upgrade the package that requires it. - Run
composer audit. It reads the same advisory data and should no longer list CVE-2026-47346. - Commit composer.lock and deploy it. On the server, run
composer install --no-devfrom the lock file, notcomposer update.
If you cannot upgrade yet
- Remove accounts you do not need and review what each role can do.
- Put the admin area behind a VPN, IP allow-list or extra login until you upgrade.
- If your app does not use the affected feature, note that in your audit, but still plan the upgrade.
The CVE-2026-47346 advisory
Backend users with file write permissions were able to upload form definition files with mixed-case extensions (e.g., .FORM.YAML) to bypass the Form Framework's upload restriction. Maliciously crafted form definition files can be used to execute arbitrary SQL statements, allowing attackers to escalate privileges by creating administrative backend user accounts. This issue affects TYPO3 CMS versions before 10.4.57, 11.0.0-11.5.50, 12.0.0-12.4.45, 13.0.0-13.4.30 and 14.0.0-14.3.2.
References
- Typo3 security advisory typo3.org
- Fix commit 2030617 github.com
- Fix commit eb2b225 github.com
Other typo3/cms-core advisories
- high CVE-2026-19418: TYPO3-CORE-SA-2026-021: Broken Access Control in Backend and Install Tool 2026-08-11
- high CVE-2026-11607: TYPO3-CORE-SA-2026-019: Broken Access Control in Form Framework 2026-06-09
- medium CVE-2026-49740: TYPO3-CORE-SA-2026-018: Insecure Deserialization in Core API 2026-06-09
- high CVE-2026-49741: TYPO3-CORE-SA-2026-017: Privilege Escalation & SQL Injection in Form Framework 2026-06-09
- low CVE-2026-49738: TYPO3-CORE-SA-2026-016: Broken Access Control in File Abstraction Layer 2026-06-09
- medium CVE-2026-47352: TYPO3-CORE-SA-2026-015: Broken Access Control in Backend API 2026-06-09
Related
Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.
Ask about a fixWhere this data comes from
- Affected and fixed versions: the Packagist security advisories API (GitHub Advisory Database and FriendsOfPHP), the same data
composer audituses. Synced 2026-11-03. - Description, score, weakness and references: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Exploited-in-the-wild status: the CISA Known Exploited Vulnerabilities catalog, checked 2026-11-04.
- Compiled by Daniel Lasek at Laskyr from the sources above. The summary, “who can exploit it”, “how to fix it” and hardening sections are our plain-English reading of the record and are generated from it. The quoted description is the record's own text. Spot an error? Tell us.